# CVE-2026-71498: node-re2: Out-of-bounds heap read in `replace`/`split` via a `Buffer` ending in a truncated multi-byte UTF-8 character → adjacent heap memory disclosed to JavaScript

> An out-of-bounds heap read in node-re2 allows attackers to disclose adjacent memory contents by passing a Buffer with a truncated UTF-8 character.

- **Severity:** Medium 5.1 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Aug 2026
- **Updated:** 7 Aug 2026
- **Also known as:** CLEANSTART-2026-PN94249, DEBIAN-CVE-2026-71498, GHSA-j4r3-hg7j-8chg, MINI-x5c2-gwrv-vjwq, UBUNTU-CVE-2026-71498

## What is CVE-2026-71498?

CVE-2026-71498 is a medium-severity vulnerability in uhop node-re2, published on 6 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

node-re2 provides RE2 regular expression bindings for Node.js. Prior to version 1.26.1, passing a Buffer whose final bytes form a truncated (incomplete) multi-byte UTF-8 sequence could cause the native binding to read past the end of the allocated buffer while attempting to decode the final, incomplete code point. This could result in an out-of-bounds read and potential disclosure of adjacent memory contents. This issue is fixed in version 1.26.1.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2026-71498?

2 open source packages ship an affected version, including re2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `re2` | npm | All versions | 1.26.1 |
| `re2` | npm | All versions | 1.26.1 |

## How do I fix CVE-2026-71498?

Upgrade re2 to 1.26.1 or later.

## Is CVE-2026-71498 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-71498 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-71498 and fix it if it is affected.

What it is: CVE-2026-71498 is a medium-severity vulnerability in uhop node-re2, published on 6 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-71498 exists.

Affected packages and fixed versions:
- re2 (npm): affected all versions; fixed in 1.26.1
- re2 (npm): affected all versions; fixed in 1.26.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-71498/ (Markdown: https://insights.sbomify.com/CVE-2026-71498/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-71498
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-71498
- OSV: https://osv.dev/vulnerability/CVE-2026-71498

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-71498/
Summaries are generated and may contain mistakes; the official description above is the record.
