# CVE-2026-71513: NLTK 3.10.0 through 3.10.2 Remote Code Execution via AllowlistUnpickler Dotted-Name Bypass

> Attackers can execute arbitrary code by crafting malicious transition-parser models that bypass allowlist checks in NLTK's unpickler.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Aug 2026
- **Updated:** 27 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-71513, GHSA-5gh2-94qg-qppq, PYSEC-2026-3867, UBUNTU-CVE-2026-71513

## What is CVE-2026-71513?

CVE-2026-71513 is a high-severity unsafe deserialization vulnerability in nltk, published on 22 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

NLTK before 3.10.3 contains a remote code execution vulnerability in AllowlistUnpickler that validates only the pickle module string and not the global name, allowing attackers to resolve dotted names by attribute traversal to callables outside the allowlisted namespace. Attackers can craft untrusted transition-parser models that execute arbitrary commands when TransitionParser.parse loads the model through allowlisted_pickle_load.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-71513?

3 open source packages ship an affected version, including nltk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nltk` | PyPI | From 3.10.0 | 3.10.3 |
| `nltk` | PyPI | From 3.10.0 | 3.10.3 |
| `nltk` | PyPI | From 3.10.0 | 3.10.3 |

Products: Nltk Nltk.

## How do I fix CVE-2026-71513?

Upgrade nltk to 3.10.3 or later.

## Is CVE-2026-71513 being exploited?

There is no known exploitation of CVE-2026-71513 in the wild and no public exploit code.

## Other vulnerabilities in nltk

- [CVE-2026-0848](https://insights.sbomify.com/CVE-2026-0848/): Arbitrary Code Execution in NLTK StanfordSegmenter via Untrusted JAR Loading (critical 10.0)
- [CVE-2025-14009](https://insights.sbomify.com/CVE-2025-14009/): Zip Slip Vulnerability in nltk/nltk Leading to Remote Code Execution (critical 10.0)
- [CVE-2026-78683](https://insights.sbomify.com/CVE-2026-78683/): NLTK before 3.10.0 Remote Code Execution via Unsafe Pickle Deserialization (critical 9.4)
- [CVE-2026-79657](https://insights.sbomify.com/CVE-2026-79657/): NLTK before 3.10.3 Remote Code Execution via Unsafe Pickle Deserialization (critical 9.3)
- [CVE-2026-79675](https://insights.sbomify.com/CVE-2026-79675/): NLTK before 3.10.3 JVM Argument Injection via Per-Call Options (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-71513 and fix it if it is affected.

What it is: CVE-2026-71513 is a high-severity unsafe deserialization vulnerability in nltk, published on 22 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-71513 in the wild and no public exploit code.

Affected packages and fixed versions:
- nltk (PyPI): affected from 3.10.0; fixed in 3.10.3
- nltk (PyPI): affected from 3.10.0; fixed in 3.10.3
- nltk (PyPI): affected from 3.10.0; fixed in 3.10.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-71513/ (Markdown: https://insights.sbomify.com/CVE-2026-71513/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-71513
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-71513
- OSV: https://osv.dev/vulnerability/CVE-2026-71513

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-71513/
Summaries are generated and may contain mistakes; the official description above is the record.
