# CVE-2026-71514: NLTK 3.9.4 through 3.10.2 Path Traversal via CrubadanCorpusReader pathsec Bypass

> An attacker controlling a corpus package can read arbitrary files outside the corpus directory via path traversal in NLTK's CrubadanCorpusReader.

- **Severity:** Low 2.0 (`CVSS:4.0/AV:L/AC:H/AT:P/PR:N/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Aug 2026
- **Updated:** 24 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-71514, ECHO-ba5b-610f-40bb, GHSA-cv22-g7mw-8v73, PYSEC-2026-3790, UBUNTU-CVE-2026-71514

## What is CVE-2026-71514?

CVE-2026-71514 is a low-severity path traversal vulnerability in nltk, published on 22 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

NLTK 3.9.4 through 3.10.2 contains a path traversal vulnerability in CrubadanCorpusReader. _load_lang_ngrams joins the corpus root with crubadan_code, the column-0 value read from the corpus table.txt mapping file, and opens the result with the builtin open() rather than the pathsec-validated opener, so os.path.join discards the root when that value is absolute and the read escapes the corpus directory without the containment check nltk.pathsec applies when ENFORCE is set. An attacker who controls a corpus package can disclose file contents outside the corpus root through lang_freq, limited to paths ending in -3grams.txt whose contents parse as token count lines.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-71514?

3 open source packages ship an affected version, including nltk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nltk` | PyPI | From 3.9.4 | 3.10.3 |
| `nltk` | PyPI | From 3.9.4 | 3.10.3 |
| `nltk` | PyPI | From 3.9.4 | 3.10.3 |

Products: Nltk Nltk.

## How do I fix CVE-2026-71514?

Upgrade nltk to 3.10.3 or later.

## Is CVE-2026-71514 being exploited?

There is no known exploitation of CVE-2026-71514 in the wild and no public exploit code.

## Other vulnerabilities in nltk

- [CVE-2026-0848](https://insights.sbomify.com/CVE-2026-0848/): Arbitrary Code Execution in NLTK StanfordSegmenter via Untrusted JAR Loading (critical 10.0)
- [CVE-2025-14009](https://insights.sbomify.com/CVE-2025-14009/): Zip Slip Vulnerability in nltk/nltk Leading to Remote Code Execution (critical 10.0)
- [CVE-2026-78683](https://insights.sbomify.com/CVE-2026-78683/): NLTK before 3.10.0 Remote Code Execution via Unsafe Pickle Deserialization (critical 9.4)
- [CVE-2026-79657](https://insights.sbomify.com/CVE-2026-79657/): NLTK before 3.10.3 Remote Code Execution via Unsafe Pickle Deserialization (critical 9.3)
- [CVE-2026-79675](https://insights.sbomify.com/CVE-2026-79675/): NLTK before 3.10.3 JVM Argument Injection via Per-Call Options (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-71514 and fix it if it is affected.

What it is: CVE-2026-71514 is a low-severity path traversal vulnerability in nltk, published on 22 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-71514 in the wild and no public exploit code.

Affected packages and fixed versions:
- nltk (PyPI): affected from 3.9.4; fixed in 3.10.3
- nltk (PyPI): affected from 3.9.4; fixed in 3.10.3
- nltk (PyPI): affected from 3.9.4; fixed in 3.10.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-71514/ (Markdown: https://insights.sbomify.com/CVE-2026-71514/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-71514
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-71514
- OSV: https://osv.dev/vulnerability/CVE-2026-71514

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-71514/
Summaries are generated and may contain mistakes; the official description above is the record.
