{"answers":{"affected":"2 open source packages ship an affected version, including paymenter/paymenter.","exploited":"There is no known exploitation of CVE-2026-71537 in the wild and no public exploit code.","fix":"Upgrade paymenter/paymenter to 1.5.7 or later.","what":"CVE-2026-71537 is a medium-severity vulnerability in Paymenter, published on 18 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-71537 and fix it if it is affected.\n\nWhat it is: CVE-2026-71537 is a medium-severity vulnerability in Paymenter, published on 18 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-71537 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- paymenter/paymenter (Packagist): affected all versions; fixed in 1.5.7\n- paymenter/paymenter (Packagist): affected all versions; fixed in 1.5.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-71537/ (Markdown: https://insights.sbomify.com/CVE-2026-71537/index.md)","id":"CVE-2026-71537","markdown":"https://insights.sbomify.com/CVE-2026-71537/index.md","name":"CVE-2026-71537","record":{"aliases":["GHSA-5gmm-hjfj-8ff7"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Hosting management platform","requires_auth":"low_privilege","summary":"An authenticated user can exploit a race condition in service downgrades to double-spend credits, resulting in unauthorized financial gains.","user_interaction":"not_required","vuln_class":"race_condition"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-362","name":"Concurrent Execution using Shared Resource with Improper Synchronization"}],"description":"Paymenter is a free and open-source webshop solution for management of hosting services. Prior to 1.5.7, app/Livewire/Services/Upgrade.php::doUpgrade() relies on Service::upgradable to check for a pending service upgrade and later executes $credit-\u003eincrement('amount', abs($price)) without DB::transaction or lockForUpdate() spanning those operations. An authenticated customer with an active downgradable service can submit concurrent downgrade requests that each observe no pending upgrade, create separate upgrade records, and increment the same account credit balance, producing multiple spendable refunds for one downgrade. This issue is fixed in version 1.5.7.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Paymenter: Credit-refund double-spend race condition in service downgrade (doUpgrade)","id":"CVE-2026-71537","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"race_condition","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"@cyclonedx/cyclonedx-npm: Shell Injection via Unsanitized --workspace Argument on Windows","id":"CVE-2026-71538"},"packages":[{"ecosystem":"Packagist","fixed":["1.5.7"],"introduced":["0"],"last_affected":[],"package":"paymenter/paymenter","purl":null,"source":"GHSA-5gmm-hjfj-8ff7"},{"ecosystem":"Packagist","fixed":["1.5.7"],"introduced":["0"],"last_affected":[],"package":"paymenter/paymenter","purl":"pkg:composer/paymenter/paymenter","source":"GHSA-5gmm-hjfj-8ff7"}],"prev":{"headline":"Typemill \u003c 2.26.0 Authorization Bypass via Media File Download Route","id":"CVE-2026-71518"},"products":["Paymenter"],"published":"2026-09-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-24","vendors":["Paymenter"]},"summary":"An authenticated user can exploit a race condition in service downgrades to double-spend credits, resulting in unauthorized financial gains.","url":"https://insights.sbomify.com/CVE-2026-71537/"}