# CVE-2026-71537: Paymenter: Credit-refund double-spend race condition in service downgrade (doUpgrade)

> An authenticated user can exploit a race condition in service downgrades to double-spend credits, resulting in unauthorized financial gains.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Sep 2026
- **Updated:** 24 Sep 2026
- **Also known as:** GHSA-5gmm-hjfj-8ff7

## What is CVE-2026-71537?

CVE-2026-71537 is a medium-severity vulnerability in Paymenter, published on 18 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Paymenter is a free and open-source webshop solution for management of hosting services. Prior to 1.5.7, app/Livewire/Services/Upgrade.php::doUpgrade() relies on Service::upgradable to check for a pending service upgrade and later executes $credit->increment('amount', abs($price)) without DB::transaction or lockForUpdate() spanning those operations. An authenticated customer with an active downgradable service can submit concurrent downgrade requests that each observe no pending upgrade, create separate upgrade records, and increment the same account credit balance, producing multiple spendable refunds for one downgrade. This issue is fixed in version 1.5.7.

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2026-71537?

2 open source packages ship an affected version, including paymenter/paymenter.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `paymenter/paymenter` | Packagist | All versions | 1.5.7 |
| `paymenter/paymenter` | Packagist | All versions | 1.5.7 |

## How do I fix CVE-2026-71537?

Upgrade paymenter/paymenter to 1.5.7 or later.

## Is CVE-2026-71537 being exploited?

There is no known exploitation of CVE-2026-71537 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-71537 and fix it if it is affected.

What it is: CVE-2026-71537 is a medium-severity vulnerability in Paymenter, published on 18 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-71537 in the wild and no public exploit code.

Affected packages and fixed versions:
- paymenter/paymenter (Packagist): affected all versions; fixed in 1.5.7
- paymenter/paymenter (Packagist): affected all versions; fixed in 1.5.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-71537/ (Markdown: https://insights.sbomify.com/CVE-2026-71537/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-71537
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-71537
- OSV: https://osv.dev/vulnerability/CVE-2026-71537

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-71537/
Summaries are generated and may contain mistakes; the official description above is the record.
