# CVE-2026-71538: @cyclonedx/cyclonedx-npm: Shell Injection via Unsanitized --workspace Argument on Windows

> Attackers can execute arbitrary OS commands on Windows via unsanitized workspace arguments in the CycloneDX npm CLI fallback path.

- **Severity:** High 8.5 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** GHSA-q69g-4hcv-6jg4

## What is CVE-2026-71538?

CVE-2026-71538 is a high-severity command injection vulnerability in cyclonedx-node-npm, published on 17 Sep 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

@cyclonedx/cyclonedx-npm creates CycloneDX Software Bill of Materials from npm projects. Prior to version 6.0.0, the Windows fallback path in src/npmRunner.ts, used when npm_execpath does not provide the npm CLI path, can construct a shell command containing an untrusted value from the --workspace option. When an attacker can influence that option and the fallback npm execution path is reached, shell metacharacters in the workspace value can execute arbitrary operating-system commands with the privileges of the user running the CLI, allowing data access, file modification, or service disruption. This issue is fixed in version 6.0.0.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-71538?

2 open source packages ship an affected version, including @cyclonedx/cyclonedx-npm.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@cyclonedx/cyclonedx-npm` | npm | All versions | 6.0.0 |
| `@cyclonedx/cyclonedx-npm` | npm | All versions | 6.0.0 |

## How do I fix CVE-2026-71538?

Upgrade @cyclonedx/cyclonedx-npm to 6.0.0 or later.

## Is CVE-2026-71538 being exploited?

There is no known exploitation of CVE-2026-71538 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-71538 and fix it if it is affected.

What it is: CVE-2026-71538 is a high-severity command injection vulnerability in cyclonedx-node-npm, published on 17 Sep 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-71538 in the wild and no public exploit code.

Affected packages and fixed versions:
- @cyclonedx/cyclonedx-npm (npm): affected all versions; fixed in 6.0.0
- @cyclonedx/cyclonedx-npm (npm): affected all versions; fixed in 6.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-71538/ (Markdown: https://insights.sbomify.com/CVE-2026-71538/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-71538
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-71538
- OSV: https://osv.dev/vulnerability/CVE-2026-71538

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-71538/
Summaries are generated and may contain mistakes; the official description above is the record.
