# CVE-2026-71539: n8n: Race Condition in Git Clone Node Allows Authenticated Users to Achieve Remote Code Execution

> Authenticated users can exploit a race condition in the Git clone node to execute arbitrary code on the server.

- **Severity:** High 8.9 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:L/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Aug 2026
- **Updated:** 19 Aug 2026
- **Also known as:** GHSA-62jr-cqgr-xmh7, MINI-863p-9g8f-3h6g

## What is CVE-2026-71539?

CVE-2026-71539 is a high-severity vulnerability in n8n-io n8n, published on 18 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

n8n is an open source workflow automation platform. Prior to 1.123.64, 2.29.8, and 2.30.1, the Git node clone operation allows an authenticated workflow user to swap a validated directory for a symlink before cloning, planting a crafted repository in the community node directory that loads as a custom JavaScript node after restart and executes arbitrary code on the server. This issue is fixed in versions 1.123.64, 2.29.8, and 2.30.1.

Weakness: CWE-367 (Time-of-check Time-of-use (TOCTOU) Race Condition)

## Which versions are affected by CVE-2026-71539?


## How do I fix CVE-2026-71539?

Upgrade to a fixed version.

## Is CVE-2026-71539 being exploited?

There is no known exploitation of CVE-2026-71539 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-71539 and fix it if it is affected.

What it is: CVE-2026-71539 is a high-severity vulnerability in n8n-io n8n, published on 18 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-71539 in the wild and no public exploit code.

Affected product: n8n-io n8n. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-71539/ (Markdown: https://insights.sbomify.com/CVE-2026-71539/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-71539
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-71539
- OSV: https://osv.dev/vulnerability/CVE-2026-71539

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-71539/
Summaries are generated and may contain mistakes; the official description above is the record.
