# CVE-2026-71543: OpenBao's Templated Policies Allow Privilege Escalation via Wildcard Characters

> Attackers can escalate privileges or issue unauthorized certificates by injecting wildcard characters into templated policies if user-controlled identity data is used.

- **Severity:** High 7.5 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Sep 2026
- **Updated:** 25 Sep 2026
- **Also known as:** BIT-openbao-2026-71543, GHSA-59w7-v8rr-pr4p, GO-2026-6556, MINI-795r-7wqr-mm6q, MINI-xjj5-xwxq-6fc5

## What is CVE-2026-71543?

CVE-2026-71543 is a high-severity vulnerability in openbao, published on 21 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

OpenBao is an open source identity-based secrets management system. Prior to 2.6.0, templated ACL, PKI, and SSH policies could substitute attacker-controlled identity data without rejecting syntax-significant characters. In ACL templated policies, asterisks, plus signs, and slashes could alter path matching. In PKI allowed_uri_sans_template and allowed_domains policies, an asterisk could broaden certificate issuance to unauthorized domains. In SSH allowed_users and allowed_domains policies, a comma could add unauthorized principals. Exploitation requires a deployment to use templated policy data that users can freely modify; templates based on the randomly generated identity.entity.id value are not affected. This could allow privilege escalation, unauthorized access, and unauthorized certificate issuance. This issue is fixed in version 2.6.0.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-71543?

6 open source packages ship an affected version, including github.com/openbao/openbao and openbao.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/openbao/openbao` | Go | All versions | 0.0.0-20260710001938-2d4ebafec5c5 |
| `github.com/openbao/openbao` | Go | All versions | 0.0.0-20260710001938-2d4ebafec5c5 |
| `github.com/openbao/openbao` | Go | All versions | 0.0.0-20260710001938-2d4ebafec5c5 |
| `github.com/openbao/openbao` | Go | From 0.1.0 to 1.1.5 | None |
| `github.com/openbao/openbao` | Go | From 0.1.0 to 1.1.5 | None |
| `openbao` | Bitnami | All versions | 2.6.0 |

## How do I fix CVE-2026-71543?

Upgrade github.com/openbao/openbao to 0.0.0-20260710001938-2d4ebafec5c5 or later.

## Is CVE-2026-71543 being exploited?

There is no known exploitation of CVE-2026-71543 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-71543 and fix it if it is affected.

What it is: CVE-2026-71543 is a high-severity vulnerability in openbao, published on 21 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-71543 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/openbao/openbao (Go): affected all versions; fixed in 0.0.0-20260710001938-2d4ebafec5c5
- github.com/openbao/openbao (Go): affected all versions; fixed in 0.0.0-20260710001938-2d4ebafec5c5
- github.com/openbao/openbao (Go): affected all versions; fixed in 0.0.0-20260710001938-2d4ebafec5c5
- github.com/openbao/openbao (Go): affected from 0.1.0 up to 1.1.5; no fix listed
- github.com/openbao/openbao (Go): affected from 0.1.0 up to 1.1.5; no fix listed
- openbao (Bitnami): affected all versions; fixed in 2.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-71543/ (Markdown: https://insights.sbomify.com/CVE-2026-71543/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-71543
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-71543
- OSV: https://osv.dev/vulnerability/CVE-2026-71543

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-71543/
Summaries are generated and may contain mistakes; the official description above is the record.
