# CVE-2026-71553: ApostropheCMS: 2nd-order prototype pollution via PATCH leading to single-request persistent DoS

> An authenticated editor can cause a persistent denial of service in ApostropheCMS by exploiting prototype pollution via a PATCH request.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Aug 2026
- **Updated:** 17 Aug 2026
- **Also known as:** GHSA-vmg4-6gfg-83qx

## What is CVE-2026-71553?

CVE-2026-71553 is a high-severity vulnerability in apostrophecms apostrophe, published on 17 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

ApostropheCMS is an open-source Node.js content management system. In 4.32.0 and earlier, PATCH /api/v1/article/:id accepts the inherited path toString.call and passes it through the utility module to apos.util.set() and apos.util.get(), allowing an authenticated editor to overwrite the shared Object.prototype.toString function's call property and cause a persistent process-wide denial of service until restart.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2026-71553?

2 open source packages ship an affected version, including apostrophe.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apostrophe` | npm | All versions | 4.32.1 |
| `apostrophe` | npm | All versions | 4.32.1 |

## How do I fix CVE-2026-71553?

Upgrade apostrophe to 4.32.1 or later.

## Is CVE-2026-71553 being exploited?

There is no known exploitation of CVE-2026-71553 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-71553 and fix it if it is affected.

What it is: CVE-2026-71553 is a high-severity vulnerability in apostrophecms apostrophe, published on 17 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-71553 in the wild and no public exploit code.

Affected packages and fixed versions:
- apostrophe (npm): affected all versions; fixed in 4.32.1
- apostrophe (npm): affected all versions; fixed in 4.32.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-71553/ (Markdown: https://insights.sbomify.com/CVE-2026-71553/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-71553
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-71553
- OSV: https://osv.dev/vulnerability/CVE-2026-71553

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-71553/
Summaries are generated and may contain mistakes; the official description above is the record.
