CVE-2026-71558 Apache Fory: Heap type confusion in C++ polymorphic smart-pointer deserialization

Critical 9.8 Published Updated

A heap type confusion in Apache Fory C++ allows attackers to execute arbitrary code or cause denial of service via crafted deserialization payloads.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-71558?

CVE-2026-71558 is a critical unsafe deserialization vulnerability in Apache Fory, published on 7 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Heap type confusion vulnerability in Apache Fory C++ deserialization.

This issue affects Apache Fory C++ versions from 0.14.0 before 1.5.0. A crafted input payload can bypass type compatibility checks during polymorphic smart-pointer deserialization, causing an object of an incompatible type to be treated as the declared base type. This may result in undefined behavior and potentially lead to denial of service or arbitrary code execution.

Users are recommended to upgrade to Apache Fory 1.5.0, which fixes this issue. Applications not using Apache Fory C++ polymorphic smart-pointer deserialization are not affected.

Weakness: CWE-843, CWE-502

Which versions are affected by CVE-2026-71558?

It affects 1 product.

Products include Apache Fory.

How do I fix CVE-2026-71558?

No fix has been published for CVE-2026-71558 yet. Limit exposure of the affected software until one is available.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2026-71558 being exploited?

There is no known exploitation of CVE-2026-71558 in the wild and no public exploit code.

Sources

Also known as GHSA-rwv5-p9fv-c8fp.

Is CVE-2026-71558 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free