# CVE-2026-71563: Apache Answer: MCP Answer Retrieval Exposes Content from Non-Public Questions

> Attackers with global API keys can access content from hidden, deleted, or pending-review questions in Apache Answer.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 19 Oct 2026
- **Updated:** 20 Oct 2026
- **Also known as:** GHSA-99v2-ggw9-c6mv

## What is CVE-2026-71563?

CVE-2026-71563 is a medium-severity missing authorization vulnerability in Apache Answer, published on 19 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Missing Authorization vulnerability in Apache Answer.

This issue affects Apache Answer: through 2.0.2.

An authorization flaw in the MCP answer retrieval tool allows holders of a global API key to access answer content associated with hidden, deleted, or pending-review questions.

Users are recommended to upgrade to version 2.0.3, which fixes the issue.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-71563?


## How do I fix CVE-2026-71563?

No fix has been published for CVE-2026-71563 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-71563 being exploited?

There is no known exploitation of CVE-2026-71563 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-71563 and fix it if it is affected.

What it is: CVE-2026-71563 is a medium-severity missing authorization vulnerability in Apache Answer, published on 19 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-71563 in the wild and no public exploit code.

Affected product: Apache Answer. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-71563/ (Markdown: https://insights.sbomify.com/CVE-2026-71563/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-71563
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-71563
- OSV: https://osv.dev/vulnerability/CVE-2026-71563

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-71563/
Summaries are generated and may contain mistakes; the official description above is the record.
