CVE-2026-7184 Mattermost Remote Cluster PATCH API Leaks Authentication Tokens
Authenticated users with specific permissions can leak remote cluster authentication tokens via unsanitized API responses, potentially enabling unauthorized access.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-7184?
CVE-2026-7184 is a medium-severity vulnerability in Mattermost Mattermost Server, published on 12 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 11.6.x <= 11.6.1, 11.5.x <= 11.5.4, 10.11.x <= 10.11.15 fail to sanitize the Remote Cluster API response on PATCH operations, which allows authenticated users with the {{manage_secure_connections}} permission to obtain remote cluster authentication tokens via a PATCH request to the remote cluster endpoint.. Mattermost Advisory ID: MMSA-2026-00662
Weakness: CWE-201
Which versions are affected by CVE-2026-7184?
12 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | From 10.11.0 | 10.11.16 |
github.com/mattermost/mattermost-server Go | From 10.11.0 | 10.11.16 |
github.com/mattermost/mattermost-server Go | From 10.11.0+incompatible | 10.11.16+incompatible, 11.5.5+incompatible, 11.6.1+incompatible |
github.com/mattermost/mattermost-server Go | From 11.5.0 | 11.5.5 |
github.com/mattermost/mattermost-server Go | From 11.5.0 | 11.5.5 |
github.com/mattermost/mattermost-server Go | From 11.6.0 | 11.6.1 |
6 more packages
github.com/mattermost/mattermost-server Go | From 11.6.0 | 11.6.1 |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | From 8.0.0-20250731163400-5b955468ea1e | 8.0.0-20260428142921-bd8fc9222672 |
github.com/mattermost/mattermost/server/v8 Go | From 8.0.0-20250731163400-5b955468ea1e | 8.0.0-20260428142921-bd8fc9222672 |
github.com/mattermost/mattermost/server/v8 Go | From 8.0.0-20250731163400-5b955468ea1e | 8.0.0-20260428142921-bd8fc9222672 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2026-7184?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.11.16, 10.11.16+incompatible, 11.5.5+incompatible or 11.6.1+incompatible.
Is CVE-2026-7184 being exploited?
There is no known exploitation of CVE-2026-7184 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-9p44-r552-4wp9, GO-2026-6282.