# CVE-2026-71858: Notepad++: shortcuts.xml Macro HMAC Bypass Enables Conditional Elevated Command Execution

> Attackers can bypass HMAC validation in shortcuts.xml to execute elevated commands and modify protected files in Notepad++.

- **Severity:** Medium 5.4 (`CVSS:4.0/AV:L/AC:H/AT:P/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 17 Aug 2026
- **Updated:** 17 Aug 2026
- **Also known as:** GHSA-f4rj-vqq4-wvg4

## What is CVE-2026-71858?

CVE-2026-71858 is a medium-severity vulnerability in notepad-plus-plus, published on 17 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Notepad++ is a free and open-source source code editor. Prior to 8.9.7, macros loaded from an attacker-controlled shortcuts.xml bypass the HMAC validation applied to UserDefinedCommands and can invoke Scintilla actions and the internal Open in Default Viewer command in an elevated Notepad++ process, allowing protected file modification and conditional elevated command execution when a local attacker influences settingsDir and a user triggers the macro. This issue is fixed in version 8.9.7.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-693 (Protection Mechanism Failure), CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2026-71858?


## How do I fix CVE-2026-71858?

No fix has been published for CVE-2026-71858 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-71858 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-71858 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-71858 and fix it if it is affected.

What it is: CVE-2026-71858 is a medium-severity vulnerability in notepad-plus-plus, published on 17 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-71858 exists.

Affected product: notepad-plus-plus. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-71858/ (Markdown: https://insights.sbomify.com/CVE-2026-71858/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-71858
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-71858
- OSV: https://osv.dev/vulnerability/CVE-2026-71858

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-71858/
Summaries are generated and may contain mistakes; the official description above is the record.
