# CVE-2026-71870: pypdf: Possible large memory usage for large /ToUnicode streams

> Attackers can cause excessive memory consumption in pypdf by crafting PDFs with large /ToUnicode streams, leading to denial of service.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Aug 2026
- **Updated:** 10 Aug 2026
- **Also known as:** CLEANSTART-2026-YN75151, DEBIAN-CVE-2026-71870, ECHO-914b-f001-9bd1, GHSA-fp3f-mc75-235c, MINI-2p7x-v96q-4cgx, MINI-3pmc-p293-g8px, MINI-554v-f598-828m, MINI-59fr-j39q-r6vm, MINI-65rv-mgmh-7h3c, MINI-8fv3-j2fq-v234, MINI-92rc-7vjc-cp2p, MINI-fp5h-p2w7-x2vp, MINI-gg6w-683q-p29w, MINI-h5c9-vpmm-2778, MINI-h842-hv86-w5v7, MINI-jj8j-rcqr-q35f, MINI-pm64-m876-f2x4, MINI-v5w9-rqvm-f425, MINI-v69h-q72c-4cqw, PYSEC-2026-3655, UBUNTU-CVE-2026-71870, openSUSE-SU-2026:11588-1

## What is CVE-2026-71870?

CVE-2026-71870 is a medium-severity denial of service vulnerability in Pypdf Project Pypdf, published on 7 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

pypdf is a free and open-source pure-python PDF library. Prior to 6.15.0, a crafted PDF can cause large memory consumption when pypdf/_cmap.py function parse_bfrange parses unusually large source-code or destination-string tokens in a font /ToUnicode CMap during text extraction. This issue is fixed in 6.15.0.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-71870?

3 open source packages ship an affected version, including pypdf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pypdf` | PyPI | All versions | 6.15.0 |
| `pypdf` | PyPI | All versions | 6.15.0 |
| `pypdf` | PyPI | All versions | 6.15.0 |
| `python-pypdf` | openSUSE:Tumbleweed | All versions | 6.16.2-1.1 |

Products: Pypdf Project Pypdf.

## How do I fix CVE-2026-71870?

Upgrade pypdf to 6.15.0 or later.

## Is CVE-2026-71870 being exploited?

There is no known exploitation of CVE-2026-71870 in the wild and no public exploit code.

## Other vulnerabilities in Pypdf Project Pypdf

- [CVE-2026-102993](https://insights.sbomify.com/CVE-2026-102993/): pypdf: Possible large memory usage when retrieving Roman page labels (high 8.7)
- [CVE-2026-102994](https://insights.sbomify.com/CVE-2026-102994/): pypdf: Possible long runtimes/large memory usage when parsing indirect objects (high 8.7)
- [CVE-2026-102995](https://insights.sbomify.com/CVE-2026-102995/): pypdf: Possible large memory usage for large /ToUnicode streams (Follow-up 2) (high 8.7)
- [CVE-2026-102996](https://insights.sbomify.com/CVE-2026-102996/): pypdf: Possible large memory usage when parsing font data (high 8.7)
- [CVE-2026-102997](https://insights.sbomify.com/CVE-2026-102997/): pypdf: Possible long runtimes for partially malformed FlateDecode streams (Follow-up) (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-71870 and fix it if it is affected.

What it is: CVE-2026-71870 is a medium-severity denial of service vulnerability in Pypdf Project Pypdf, published on 7 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-71870 in the wild and no public exploit code.

Affected packages and fixed versions:
- pypdf (PyPI): affected all versions; fixed in 6.15.0
- pypdf (PyPI): affected all versions; fixed in 6.15.0
- pypdf (PyPI): affected all versions; fixed in 6.15.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-71870/ (Markdown: https://insights.sbomify.com/CVE-2026-71870/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-71870
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-71870
- OSV: https://osv.dev/vulnerability/CVE-2026-71870

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-71870/
Summaries are generated and may contain mistakes; the official description above is the record.
