# CVE-2026-71871: Orval: Import-time RCE via header-parameter default -> zod module-level template literal

> Attacker-controlled input in OpenAPI specs can execute arbitrary code during client generation or import, affecting developers and CI environments.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Aug 2026
- **Updated:** 21 Aug 2026
- **Also known as:** GHSA-8j6p-r8jg-mxqh, ROOT-APP-NPM-CVE-2026-71871

## What is CVE-2026-71871?

CVE-2026-71871 is a critical code injection vulnerability in orval-labs orval, published on 19 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Orval generates type-safe JavaScript clients in TypeScript from OpenAPI v3 and Swagger v2 specifications. Prior to 8.21.0, a ${...} expression or backtick in a header parameter default is emitted into a module-level template literal emitted by zod schema generation without safe encoding. This permits attacker-controlled JavaScript to be evaluated when the generated zod schema module is imported, resulting in code execution in the developer, CI, test, or application environment. The affected code is packages/zod/src/index.ts function formatDefaultValue. This issue is fixed in version 8.21.0.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-1336 (Improper Neutralization of Special Elements Used in a Template Engine), CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2026-71871?

2 open source packages ship an affected version, including orval.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `orval` | npm | All versions | 8.21.0 |
| `orval` | npm | All versions | 8.21.0 |

## How do I fix CVE-2026-71871?

Upgrade orval to 8.21.0 or later.

## Is CVE-2026-71871 being exploited?

There is no known exploitation of CVE-2026-71871 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-71871 and fix it if it is affected.

What it is: CVE-2026-71871 is a critical code injection vulnerability in orval-labs orval, published on 19 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-71871 in the wild and no public exploit code.

Affected packages and fixed versions:
- orval (npm): affected all versions; fixed in 8.21.0
- orval (npm): affected all versions; fixed in 8.21.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-71871/ (Markdown: https://insights.sbomify.com/CVE-2026-71871/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-71871
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-71871
- OSV: https://osv.dev/vulnerability/CVE-2026-71871

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-71871/
Summaries are generated and may contain mistakes; the official description above is the record.
