# CVE-2026-71898: An incorrect authorization check in Apache DolphinScheduler allows an authenticated user with only read permission for a project to modify a


- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 29 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** GHSA-7jf5-57qv-9q6r

## What is CVE-2026-71898?

CVE-2026-71898 is a medium-severity vulnerability in Apache DolphinScheduler, published on 29 Sep 2026. 

### Official description

An incorrect authorization check in Apache DolphinScheduler allows an authenticated user with only read permission for a project to modify a workflow instance in that project through the PUT /projects/{projectCode}/workflow-instances/{id} endpoint. The endpoint does not enforce the write permission required for this operation, allowing the user to make unauthorized changes to workflow instances.

This issue affects Apache DolphinScheduler: before 3.4.3.

Users are recommended to upgrade to version 3.4.3, which fixes the issue.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-71898?


## How do I fix CVE-2026-71898?

No fix has been published for CVE-2026-71898 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-71898 being exploited?

There is no known exploitation of CVE-2026-71898 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-71898 and fix it if it is affected.

What it is: CVE-2026-71898 is a medium-severity vulnerability in Apache DolphinScheduler, published on 29 Sep 2026. 
Exploitation: There is no known exploitation of CVE-2026-71898 in the wild and no public exploit code.

Affected product: Apache DolphinScheduler. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-71898/ (Markdown: https://insights.sbomify.com/CVE-2026-71898/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-71898
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-71898
- OSV: https://osv.dev/vulnerability/CVE-2026-71898

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-71898/
Summaries are generated and may contain mistakes; the official description above is the record.
