# CVE-2026-7191: Arbitrary Code Execution via Sandbox Bypass in the open source solution QnABot on AWS

> An authenticated administrator can execute arbitrary code and access backend resources by bypassing the expression sandbox in QnABot on AWS.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 27 Apr 2026
- **Updated:** 28 Apr 2026

## What is CVE-2026-7191?

CVE-2026-7191 is a high-severity code injection vulnerability in QnABot on AWS, published on 27 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Improper use of the static-eval npm package in the open source solution qnabot-on-aws versions 7.2.4 and earlier may allow an authenticated administrator to execute arbitrary code within the fulfillment Lambda execution context by injecting a crafted conditional chaining expression via the Content Designer interface, which bypasses the intended expression sandbox through JavaScript prototype manipulation. This may grant direct access to backend resources (Lambda environment variables, OpenSearch indices, S3 objects, DynamoDB tables) that are not exposed through normal administrative interfaces.

We recommend you upgrade to version 7.3.0 or above.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-7191?


## How do I fix CVE-2026-7191?

No fix has been published for CVE-2026-7191 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-7191 being exploited?

There is no known exploitation of CVE-2026-7191 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-7191 and fix it if it is affected.

What it is: CVE-2026-7191 is a high-severity code injection vulnerability in QnABot on AWS, published on 27 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-7191 in the wild and no public exploit code.

Affected product: QnABot on AWS. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-7191/ (Markdown: https://insights.sbomify.com/CVE-2026-7191/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-7191
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-7191
- OSV: https://osv.dev/vulnerability/CVE-2026-7191

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-7191/
Summaries are generated and may contain mistakes; the official description above is the record.
