CVE-2026-7210 The expat and elementtree parsers use insufficient entropy for XML hash-flooding protection
Attackers can cause denial of service in Python applications by sending crafted XML documents that exploit insufficient entropy in hash-flooding protection.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-7210?
CVE-2026-7210 is a medium-severity denial of service vulnerability in Python Python, published on 11 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
`xml.parsers.expat` and `xml.etree.ElementTree` use insufficient entropy for Expat hash-flooding protection, which allows a crafted XML document to trigger hash flooding.\r\n\r\nFully mitigating this vulnerability requires both updating libexpat to 2.8.0 or later and applying this patch.
Weakness: CWE-331
Which versions are affected by CVE-2026-7210?
3 open source packages ship an affected version, including libpython, python and python-min. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
libpython Bitnami | All versions | 3.10.22, 3.11.16, 3.12.14, 3.13.14, 3.14.6 |
python Bitnami | All versions | 3.10.22, 3.11.16, 3.12.14, 3.13.14, 3.14.6 |
python-min Bitnami | All versions | 3.10.22, 3.11.16, 3.12.14, 3.13.14, 3.14.6 |
Linux distribution packages (7)
python3.10 Red Hat:hummingbird:1 | All versions | 0:3.10.21-1.4.hum1 |
python3.10-debug Red Hat:hummingbird:1 | All versions | 0:3.10.21-1.4.hum1 |
python3.10-devel Red Hat:hummingbird:1 | All versions | 0:3.10.21-1.4.hum1 |
python3.10-idle Red Hat:hummingbird:1 | All versions | 0:3.10.21-1.4.hum1 |
python3.10-libs Red Hat:hummingbird:1 | All versions | 0:3.10.21-1.4.hum1 |
python3.10-test Red Hat:hummingbird:1 | All versions | 0:3.10.21-1.4.hum1 |
python3.10-tkinter Red Hat:hummingbird:1 | All versions | 0:3.10.21-1.4.hum1 |
Products include Python Python.
How do I fix CVE-2026-7210?
Upgrade libpython to a fixed version for your release line: 3.10.22, 3.11.16, 3.12.14 or 3.13.14.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-7210 being exploited?
There is no known exploitation of CVE-2026-7210 in the wild and no public exploit code.
Other vulnerabilities in Python Python
Sources
Also known as ALPINE-CVE-2026-7210, AZL-109719, AZL-86784, BELL-CVE-2026-7210, BIT-libpython-2026-7210, BIT-python-2026-7210 and 37 more.