# CVE-2026-7210: The expat and elementtree parsers use insufficient entropy for XML hash-flooding protection

> Attackers can cause denial of service in Python applications by sending crafted XML documents that exploit insufficient entropy in hash-flooding protection.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 May 2026
- **Updated:** 2 Oct 2026
- **Also known as:** ALPINE-CVE-2026-7210, AZL-109719, AZL-86784, BELL-CVE-2026-7210, BIT-libpython-2026-7210, BIT-python-2026-7210, BIT-python-min-2026-7210, CLSA-2026-1780647966, CLSA-2026-1780675586, CLSA-2026-1780675974, CLSA-2026-1780676175, CLSA-2026-1780698006, CLSA-2026-1780699080, CLSA-2026-1780700238, CLSA-2026-1780700848, CLSA-2026-1780703662, CLSA-2026-1780705020, CLSA-2026-1780705975, CLSA-2026-1780951704, CLSA-2026-1781169880, CLSA-2026-1781179629, CLSA-2026-1781190400, CLSA-2026-1781252611, CLSA-2026-1781346632, CLSA-2026-1782140460, DEBIAN-CVE-2026-7210, ECHO-63fc-2f8a-5391, GHSA-wxv8-w48j-r2f4, MINI-38m8-ccm9-6cff, MINI-3jm4-x46w-pwh7, MINI-jm8j-3j39-x6vj, MINI-pqp6-xp34-p3mw, MINI-wvjr-8g2f-8rw6, OESA-2026-3178, OESA-2026-3179, PSF-2026-23, RHSA-2026:69069, ROOT-OS-ALPINE-320-CVE-2026-7210, ROOT-OS-DEBIAN-11-CVE-2026-7210, ROOT-OS-DEBIAN-12-CVE-2026-7210, ROOT-OS-DEBIAN-13-CVE-2026-7210, UBUNTU-CVE-2026-7210, USN-8524-1

## What is CVE-2026-7210?

CVE-2026-7210 is a medium-severity denial of service vulnerability in Python Python, published on 11 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

`xml.parsers.expat` and `xml.etree.ElementTree` use insufficient entropy for Expat hash-flooding protection, which allows a crafted XML document to trigger hash flooding.\r\n\r\nFully mitigating this vulnerability requires both updating libexpat to 2.8.0 or later and applying this patch.

Weakness: CWE-331 (Insufficient Entropy)

## Which versions are affected by CVE-2026-7210?

3 open source packages ship an affected version, including libpython, python and python-min. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libpython` | Bitnami | All versions | 3.10.22, 3.11.16, 3.12.14, 3.13.14, 3.14.6 |
| `python` | Bitnami | All versions | 3.10.22, 3.11.16, 3.12.14, 3.13.14, 3.14.6 |
| `python-min` | Bitnami | All versions | 3.10.22, 3.11.16, 3.12.14, 3.13.14, 3.14.6 |
| `python3.10` | Red Hat:hummingbird:1 | All versions | 0:3.10.21-1.4.hum1 |
| `python3.10-debug` | Red Hat:hummingbird:1 | All versions | 0:3.10.21-1.4.hum1 |
| `python3.10-devel` | Red Hat:hummingbird:1 | All versions | 0:3.10.21-1.4.hum1 |
| `python3.10-idle` | Red Hat:hummingbird:1 | All versions | 0:3.10.21-1.4.hum1 |
| `python3.10-libs` | Red Hat:hummingbird:1 | All versions | 0:3.10.21-1.4.hum1 |
| `python3.10-test` | Red Hat:hummingbird:1 | All versions | 0:3.10.21-1.4.hum1 |
| `python3.10-tkinter` | Red Hat:hummingbird:1 | All versions | 0:3.10.21-1.4.hum1 |

Products: Python Python.

## How do I fix CVE-2026-7210?

Upgrade libpython to a fixed version for your release line: 3.10.22, 3.11.16, 3.12.14 or 3.13.14.

## Is CVE-2026-7210 being exploited?

There is no known exploitation of CVE-2026-7210 in the wild and no public exploit code.

## Other vulnerabilities in Python Python

- [CVE-2008-5031](https://insights.sbomify.com/CVE-2008-5031/): Integer overflow in n/a (critical 10.0)
- [CVE-2014-4650](https://insights.sbomify.com/CVE-2014-4650/): Path traversal in n/a (critical 9.8)
- [CVE-2016-5636](https://insights.sbomify.com/CVE-2016-5636/): Integer overflow in n/a (critical 9.8)
- [CVE-2007-4559](https://insights.sbomify.com/CVE-2007-4559/): Path traversal in n/a (critical 9.8)
- [CVE-2017-17522](https://insights.sbomify.com/CVE-2017-17522/): Command injection in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-7210 and fix it if it is affected.

What it is: CVE-2026-7210 is a medium-severity denial of service vulnerability in Python Python, published on 11 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-7210 in the wild and no public exploit code.

Affected packages and fixed versions:
- libpython (Bitnami): affected all versions; fixed in 3.10.22, 3.11.16, 3.12.14, 3.13.14, 3.14.6
- python (Bitnami): affected all versions; fixed in 3.10.22, 3.11.16, 3.12.14, 3.13.14, 3.14.6
- python-min (Bitnami): affected all versions; fixed in 3.10.22, 3.11.16, 3.12.14, 3.13.14, 3.14.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-7210/ (Markdown: https://insights.sbomify.com/CVE-2026-7210/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-7210
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-7210
- OSV: https://osv.dev/vulnerability/CVE-2026-7210

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-7210/
Summaries are generated and may contain mistakes; the official description above is the record.
