CVE-2026-7250 Allocation of Resources Without Limits or Throttling in GitLab

High 7.5 Published Updated

An unauthenticated attacker can cause denial of service in GitLab via improper input validation in API request parsing middleware.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-7250?

CVE-2026-7250 is a high-severity denial of service vulnerability in Gitlab Gitlab, published on 11 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 12.10 before 18.10.8, 18.11 before 18.11.5, and 19.0 before 19.0.2 that under certain conditions could have allowed an unauthenticated user to cause denial of service due to improper input validation in the API request parsing middleware.

Weakness: CWE-770

Which versions are affected by CVE-2026-7250?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 12.10.018.10.8, 18.11.5, 19.0.2

Products include Gitlab Gitlab.

How do I fix CVE-2026-7250?

Upgrade gitlab to a fixed version for your release line: 18.10.8, 18.11.5 or 19.0.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-7250 being exploited?

There is no known exploitation of CVE-2026-7250 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2026-7250, GHSA-cx4g-hr74-m89m, MINI-2gq4-jr42-fvmr, MINI-2v2f-x6m9-rwfj, MINI-3636-hpp4-3jm9, MINI-3cc9-hm47-hx78 and 41 more.

Is CVE-2026-7250 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free