# CVE-2026-7250: Allocation of Resources Without Limits or Throttling in GitLab

> An unauthenticated attacker can cause denial of service in GitLab via improper input validation in API request parsing middleware.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jun 2026
- **Updated:** 11 Jun 2026
- **Also known as:** BIT-gitlab-2026-7250, GHSA-cx4g-hr74-m89m, MINI-2gq4-jr42-fvmr, MINI-2v2f-x6m9-rwfj, MINI-3636-hpp4-3jm9, MINI-3cc9-hm47-hx78, MINI-5p8r-w8hr-25h6, MINI-5xf9-2gxf-5cj2, MINI-6ggj-qpr9-62xg, MINI-6w42-rgh9-w453, MINI-94mp-2wwg-7wp2, MINI-9jjv-ppwv-hcjc, MINI-c499-fc2r-hc6j, MINI-c63m-cwfx-vj6f, MINI-c6wq-f7p7-6967, MINI-cp65-c7j5-cxv4, MINI-cpf2-6ww5-24x9, MINI-f6pw-pv3x-x2mv, MINI-f999-9c4v-qf8p, MINI-fcc4-gqh3-6fjr, MINI-ffgw-jmfc-5cvh, MINI-fhc4-r5jc-v3hm, MINI-g884-6v6q-532v, MINI-gr8g-p29j-gr7g, MINI-h638-6mfj-5j64, MINI-h7f8-68q7-p69g, MINI-hc6x-72h8-4jpx, MINI-hfmw-hrmw-mmxf, MINI-hg8q-744g-wv3m, MINI-j9c9-jvxw-q6jc, MINI-jpqm-pr6h-5fr6, MINI-m48m-wqww-7h7v, MINI-mfgj-66wm-h2f5, MINI-mmjc-96pg-g6hh, MINI-mpwv-qp2g-68j9, MINI-p62w-994h-8rpj, MINI-q4mg-mfwh-8mp9, MINI-qc96-7mq6-jjc7, MINI-rjfc-2wx9-f297, MINI-v89h-6w5q-5mwg, MINI-vmxj-r8m8-cf3r, MINI-w7xj-cpgf-jh66, MINI-x52x-4xmg-f536, MINI-x797-rpcx-3rwh, MINI-x7xg-rvwp-6374, MINI-xw45-prqx-549r, UBUNTU-CVE-2026-7250

## What is CVE-2026-7250?

CVE-2026-7250 is a high-severity denial of service vulnerability in Gitlab Gitlab, published on 11 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 12.10 before 18.10.8, 18.11 before 18.11.5, and 19.0 before 19.0.2 that under certain conditions could have allowed an unauthenticated user to cause denial of service due to improper input validation in the API request parsing middleware.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-7250?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | From 12.10.0 | 18.10.8, 18.11.5, 19.0.2 |

Products: Gitlab Gitlab.

## How do I fix CVE-2026-7250?

Upgrade gitlab to a fixed version for your release line: 18.10.8, 18.11.5 or 19.0.2.

## Is CVE-2026-7250 being exploited?

There is no known exploitation of CVE-2026-7250 in the wild and no public exploit code.

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-7250 and fix it if it is affected.

What it is: CVE-2026-7250 is a high-severity denial of service vulnerability in Gitlab Gitlab, published on 11 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-7250 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitlab (Bitnami): affected from 12.10.0; fixed in 18.10.8, 18.11.5, 19.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-7250/ (Markdown: https://insights.sbomify.com/CVE-2026-7250/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-7250
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-7250
- OSV: https://osv.dev/vulnerability/CVE-2026-7250

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-7250/
Summaries are generated and may contain mistakes; the official description above is the record.
