CVE-2026-7258 Out-of-bounds read in urldecode() on NetBSD
An out-of-bounds read in PHP's urldecode function on NetBSD systems can cause a denial of service due to negative array offsets.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-7258?
CVE-2026-7258 is a medium-severity denial of service vulnerability in Php Php, published on 10 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In PHP versions 8.2.* before 8.2.31, 8.3.* before 8.3.31, 8.4.* before 8.4.21, and 8.5.* before 8.5.6, some functions, including urldecode(), pass signed char to ctype functions (like isxdigit()). On the systems with default signed char and optimized table-lookup ctype functions - such as NetBSD - this can lead to accessing array with negative offset, which can trigger a denial of service.
Weakness: CWE-125
Which versions are affected by CVE-2026-7258?
3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
libphp Bitnami | From 8.2.0 | 8.2.31, 8.3.31, 8.4.21, 8.5.6 |
php Bitnami | From 8.2.0 | 8.2.31, 8.3.31, 8.4.21, 8.5.6 |
php-min Bitnami | From 8.2.0 | 8.2.31, 8.3.31, 8.4.21, 8.5.6 |
Products include Php Php.
How do I fix CVE-2026-7258?
Upgrade libphp to a fixed version for your release line: 8.2.31, 8.3.31, 8.4.21 or 8.5.6.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-7258 being exploited?
There is no known exploitation of CVE-2026-7258 in the wild and no public exploit code.
Other vulnerabilities in Php Php
Sources
Also known as AZL-86346, BELL-CVE-2026-7258, BIT-libphp-2026-7258, BIT-php-2026-7258, BIT-php-min-2026-7258, CLSA-2026-1779887887 and 8 more.