# CVE-2026-7259: Null pointer dereference in php_mb_check_encoding() via mb_ereg_search_init()

> A null pointer dereference in PHP's mb_ereg_search_init function allows attackers to cause a denial of service via crafted encoding inputs.

- **Severity:** Low 2.1 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:N/VI:N/VA:L/SC:N/SI:N/SA:L/AU:Y/U:Amber`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 May 2026
- **Updated:** 11 May 2026
- **Also known as:** AZL-86364, BELL-CVE-2026-7259, BIT-libphp-2026-7259, BIT-php-2026-7259, BIT-php-min-2026-7259, DEBIAN-CVE-2026-7259, ECHO-5b8a-520f-24a9, MINI-7wgg-g7x9-hr5p, MINI-8fv9-4h35-vq4m, MINI-fv72-jxw9-cgfh, MINI-jm5m-hhfc-wh7v, UBUNTU-CVE-2026-7259

## What is CVE-2026-7259?

CVE-2026-7259 is a low-severity vulnerability in Php Php, published on 10 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In PHP versions 8.2.* before 8.2.31, 8.3.* before 8.3.31, 8.4.* before 8.4.21, and 8.5.* before 8.5.6, a mismatch between encoding lists in Oniguruma and mbfl leads to  a NULL pointer dereference, resulting in a segmentation fault and denial of service. The vulnerability is exploitable when user-controlled input can influence the encoding passed to mb_regex_encoding().

Weakness: CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2026-7259?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libphp` | Bitnami | From 8.2.0 | 8.2.31, 8.3.31, 8.4.21, 8.5.6 |
| `php` | Bitnami | From 8.2.0 | 8.2.31, 8.3.31, 8.4.21, 8.5.6 |
| `php-min` | Bitnami | From 8.2.0 | 8.2.31, 8.3.31, 8.4.21, 8.5.6 |

Products: Php Php.

## How do I fix CVE-2026-7259?

Upgrade libphp to a fixed version for your release line: 8.2.31, 8.3.31, 8.4.21 or 8.5.6.

## Is CVE-2026-7259 being exploited?

There is no known exploitation of CVE-2026-7259 in the wild and no public exploit code.

## Other vulnerabilities in Php Php

- [CVE-2012-2688](https://insights.sbomify.com/CVE-2012-2688/): Integer overflow in n/a (critical 10.0)
- [CVE-2012-2376](https://insights.sbomify.com/CVE-2012-2376/): Memory corruption in n/a (critical 10.0)
- [CVE-2011-3268](https://insights.sbomify.com/CVE-2011-3268/): Memory corruption in n/a (critical 10.0)
- [CVE-2009-4143](https://insights.sbomify.com/CVE-2009-4143/): Other in n/a (critical 10.0)
- [CVE-2008-5557](https://insights.sbomify.com/CVE-2008-5557/): Memory corruption in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-7259 and fix it if it is affected.

What it is: CVE-2026-7259 is a low-severity vulnerability in Php Php, published on 10 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-7259 in the wild and no public exploit code.

Affected packages and fixed versions:
- libphp (Bitnami): affected from 8.2.0; fixed in 8.2.31, 8.3.31, 8.4.21, 8.5.6
- php (Bitnami): affected from 8.2.0; fixed in 8.2.31, 8.3.31, 8.4.21, 8.5.6
- php-min (Bitnami): affected from 8.2.0; fixed in 8.2.31, 8.3.31, 8.4.21, 8.5.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-7259/ (Markdown: https://insights.sbomify.com/CVE-2026-7259/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-7259
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-7259
- OSV: https://osv.dev/vulnerability/CVE-2026-7259

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-7259/
Summaries are generated and may contain mistakes; the official description above is the record.
