CVE-2026-7260 Stack overflow in phar with circular symlinks

Medium 5.4 Published Updated

An attacker can crash the PHP process by providing a phar archive with circular symlinks, causing a stack overflow.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-7260?

CVE-2026-7260 is a medium-severity denial of service vulnerability in Php Php, published on 30 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

Official description

Circular symbolic links in phar archives could lead to unbounded recursion, exhausting the C stack and crashing the PHP process, in PHP versions from 8.2.* before 8.2.33, from 8.3.* before 8.3.33, from 8.4.* before 8.4.24, and from 8.5.* before 8.5.9.

Weakness: CWE-121

Which versions are affected by CVE-2026-7260?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.

PackageAffectedFixed in
libphp BitnamiFrom 8.2.08.2.33, 8.3.33, 8.4.24, 8.5.9
php BitnamiFrom 8.2.08.2.33, 8.3.33, 8.4.24, 8.5.9
php-min BitnamiFrom 8.2.08.2.33, 8.3.33, 8.4.24, 8.5.9
Linux distribution packages (37)
apache2-mod_php7 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOSAll versions7.4.33-150400.4.73.1
php7 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOSAll versions7.4.33-150400.4.73.1
php7-fastcgi SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOSAll versions7.4.33-150400.4.73.1
php7-fpm SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOSAll versions7.4.33-150400.4.73.1
apache2-mod_php7 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSSAll versions7.4.33-150400.4.73.1
php7 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSSAll versions7.4.33-150400.4.73.1
php7-fastcgi SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSSAll versions7.4.33-150400.4.73.1
php7-fpm SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSSAll versions7.4.33-150400.4.73.1
apache2-mod_php7 SUSE:Linux Enterprise Module for Legacy 15 SP7All versions7.4.33-150400.4.73.1
php7 SUSE:Linux Enterprise Module for Legacy 15 SP7All versions7.4.33-150400.4.73.1
apache2-mod_php7 SUSE:Linux Enterprise Module for Package Hub 15 SP7All versions7.4.33-150400.4.73.1
php7 SUSE:Linux Enterprise Module for Package Hub 15 SP7All versions7.4.33-150400.4.73.1
php7-embed SUSE:Linux Enterprise Module for Package Hub 15 SP7All versions7.4.33-150400.4.73.1
php7-fastcgi SUSE:Linux Enterprise Module for Package Hub 15 SP7All versions7.4.33-150400.4.73.1
php7-fpm SUSE:Linux Enterprise Module for Package Hub 15 SP7All versions7.4.33-150400.4.73.1
php7-test SUSE:Linux Enterprise Module for Package Hub 15 SP7All versions7.4.33-150400.4.73.1
apache2-mod_php7 SUSE:Linux Enterprise Server 15 SP4-LTSSAll versions7.4.33-150400.4.73.1
php7 SUSE:Linux Enterprise Server 15 SP4-LTSSAll versions7.4.33-150400.4.73.1
php7-fastcgi SUSE:Linux Enterprise Server 15 SP4-LTSSAll versions7.4.33-150400.4.73.1
php7-fpm SUSE:Linux Enterprise Server 15 SP4-LTSSAll versions7.4.33-150400.4.73.1
apache2-mod_php7 SUSE:Linux Enterprise Server 15 SP5-LTSSAll versions7.4.33-150400.4.73.1
php7 SUSE:Linux Enterprise Server 15 SP5-LTSSAll versions7.4.33-150400.4.73.1
php7-fastcgi SUSE:Linux Enterprise Server 15 SP5-LTSSAll versions7.4.33-150400.4.73.1
php7-fpm SUSE:Linux Enterprise Server 15 SP5-LTSSAll versions7.4.33-150400.4.73.1
apache2-mod_php7 SUSE:Linux Enterprise Server 15 SP6-LTSSAll versions7.4.33-150400.4.73.1
php7 SUSE:Linux Enterprise Server 15 SP6-LTSSAll versions7.4.33-150400.4.73.1
php7-fastcgi SUSE:Linux Enterprise Server 15 SP6-LTSSAll versions7.4.33-150400.4.73.1
php7-fpm SUSE:Linux Enterprise Server 15 SP6-LTSSAll versions7.4.33-150400.4.73.1
apache2-mod_php7 SUSE:Linux Enterprise Server for SAP Applications 15 SP4All versions7.4.33-150400.4.73.1
php7 SUSE:Linux Enterprise Server for SAP Applications 15 SP4All versions7.4.33-150400.4.73.1
php7-fastcgi SUSE:Linux Enterprise Server for SAP Applications 15 SP4All versions7.4.33-150400.4.73.1
php7-fpm SUSE:Linux Enterprise Server for SAP Applications 15 SP4All versions7.4.33-150400.4.73.1
apache2-mod_php7 SUSE:Linux Enterprise Server for SAP Applications 15 SP5All versions7.4.33-150400.4.73.1
php7 SUSE:Linux Enterprise Server for SAP Applications 15 SP5All versions7.4.33-150400.4.73.1
php7-fastcgi SUSE:Linux Enterprise Server for SAP Applications 15 SP5All versions7.4.33-150400.4.73.1
php7-fpm SUSE:Linux Enterprise Server for SAP Applications 15 SP5All versions7.4.33-150400.4.73.1
apache2-mod_php7 SUSE:Linux Enterprise Server for SAP Applications 15 SP6All versions7.4.33-150400.4.73.1

Products include Php Php.

How do I fix CVE-2026-7260?

Upgrade libphp to a fixed version for your release line: 8.2.33, 8.3.33, 8.4.24 or 8.5.9.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-7260 being exploited?

There is no known exploitation of CVE-2026-7260 in the wild and no public exploit code.

All Php Php vulnerabilities

Sources

Also known as AZL-94181, BELL-CVE-2026-7260, BIT-libphp-2026-7260, BIT-php-2026-7260, BIT-php-min-2026-7260, CLSA-2026-1785836427 and 11 more.

Is CVE-2026-7260 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free