{"answers":{"affected":"3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-7261 in the wild and no public exploit code.","fix":"Upgrade libphp to a fixed version for your release line: 8.2.31, 8.3.31, 8.4.21 or 8.5.6.","what":"CVE-2026-7261 is a medium-severity use after free vulnerability in Php Php, published on 10 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-7261 and fix it if it is affected.\n\nWhat it is: CVE-2026-7261 is a medium-severity use after free vulnerability in Php Php, published on 10 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-7261 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- libphp (Bitnami): affected from 8.2.0; fixed in 8.2.31, 8.3.31, 8.4.21, 8.5.6\n- php (Bitnami): affected from 8.2.0; fixed in 8.2.31, 8.3.31, 8.4.21, 8.5.6\n- php-min (Bitnami): affected from 8.2.0; fixed in 8.2.31, 8.3.31, 8.4.21, 8.5.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-7261/ (Markdown: https://insights.sbomify.com/CVE-2026-7261/index.md)","id":"CVE-2026-7261","markdown":"https://insights.sbomify.com/CVE-2026-7261/index.md","name":"CVE-2026-7261","record":{"aliases":["AZL-86343","BELL-CVE-2026-7261","BIT-libphp-2026-7261","BIT-php-2026-7261","BIT-php-min-2026-7261","DEBIAN-CVE-2026-7261","ECHO-732b-3517-c92a","MINI-882j-m4hh-wh75","MINI-pr28-x7p2-qggj","MINI-qvf7-42xv-8q33","MINI-xgvp-83m9-2pj7","UBUNTU-CVE-2026-7261"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"PHP SOAP server","requires_auth":"none","summary":"A use-after-free vulnerability in PHP SoapServer with session persistence allows attackers to cause memory corruption, crashes, or potentially execute code.","user_interaction":"not_required","vuln_class":"use_after_free"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"php","cpe":[{"product":"php","vendor":"php"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L/S:P/AU:Y/RE:M/U:Amber","version":"4.0"},"cwes":[{"id":"CWE-416","name":"Use After Free"}],"description":"In PHP versions 8.2.* before 8.2.31, 8.3.* before 8.3.31, 8.4.* before 8.4.21, and 8.5.* before 8.5.6, when SoapServer is configured with SOAP_PERSISTENCE_SESSION, the handler object is persisted across requests via session storage. However, in the case SOAP requests results in an error, the persistance is handled incorrectly, resulting in freeing the object while keeping a pointer to it, which may lead to use-after-free. This may lead to memory corruption, information disclosure, or process crashes, with confidentiality, integrity, and availability impact on the vulnerable system.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"SoapServer session-persisted object use-after-free via SOAP header fault","id":"CVE-2026-7261","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"php:php","products":["php:php"],"type":"use_after_free","year":"2026"},"n_packages":3,"n_references":1,"next":{"headline":"NULL pointer dereference in SOAP apache:Map decoder with missing \u003cvalue\u003e","id":"CVE-2026-7262"},"packages":[{"ecosystem":"Bitnami","fixed":["8.2.31","8.3.31","8.4.21","8.5.6"],"introduced":["8.2.0","8.3.0","8.4.0","8.5.0"],"last_affected":[],"package":"libphp","purl":"pkg:bitnami/libphp","source":"BIT-libphp-2026-7261"},{"ecosystem":"Bitnami","fixed":["8.2.31","8.3.31","8.4.21","8.5.6"],"introduced":["8.2.0","8.3.0","8.4.0","8.5.0"],"last_affected":[],"package":"php","purl":"pkg:bitnami/php","source":"BIT-php-2026-7261"},{"ecosystem":"Bitnami","fixed":["8.2.31","8.3.31","8.4.21","8.5.6"],"introduced":["8.2.0","8.3.0","8.4.0","8.5.0"],"last_affected":[],"package":"php-min","purl":"pkg:bitnami/php-min","source":"BIT-php-min-2026-7261"}],"prev":{"headline":"Stack overflow in phar with circular symlinks","id":"CVE-2026-7260"},"products":["PHP"],"published":"2026-05-10","related":[{"cvss_score":10,"headline":"Integer overflow in n/a","id":"CVE-2012-2688","kev_date_added":null,"published":"2012-07-20"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2012-2376","kev_date_added":null,"published":"2012-05-21"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2011-3268","kev_date_added":null,"published":"2011-08-25"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2009-4143","kev_date_added":null,"published":"2009-12-21"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2008-5557","kev_date_added":null,"published":"2008-12-23"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2008-2050","kev_date_added":null,"published":"2008-05-05"},{"cvss_score":10,"headline":"Command injection in n/a","id":"CVE-2008-2051","kev_date_added":null,"published":"2008-05-05"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-11","vendors":["PHP Group"]},"summary":"A use-after-free vulnerability in PHP SoapServer with session persistence allows attackers to cause memory corruption, crashes, or potentially execute code.","url":"https://insights.sbomify.com/CVE-2026-7261/"}