# CVE-2026-7261: SoapServer session-persisted object use-after-free via SOAP header fault

> A use-after-free vulnerability in PHP SoapServer with session persistence allows attackers to cause memory corruption, crashes, or potentially execute code.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L/S:P/AU:Y/RE:M/U:Amber`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 May 2026
- **Updated:** 11 May 2026
- **Also known as:** AZL-86343, BELL-CVE-2026-7261, BIT-libphp-2026-7261, BIT-php-2026-7261, BIT-php-min-2026-7261, DEBIAN-CVE-2026-7261, ECHO-732b-3517-c92a, MINI-882j-m4hh-wh75, MINI-pr28-x7p2-qggj, MINI-qvf7-42xv-8q33, MINI-xgvp-83m9-2pj7, UBUNTU-CVE-2026-7261

## What is CVE-2026-7261?

CVE-2026-7261 is a medium-severity use after free vulnerability in Php Php, published on 10 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In PHP versions 8.2.* before 8.2.31, 8.3.* before 8.3.31, 8.4.* before 8.4.21, and 8.5.* before 8.5.6, when SoapServer is configured with SOAP_PERSISTENCE_SESSION, the handler object is persisted across requests via session storage. However, in the case SOAP requests results in an error, the persistance is handled incorrectly, resulting in freeing the object while keeping a pointer to it, which may lead to use-after-free. This may lead to memory corruption, information disclosure, or process crashes, with confidentiality, integrity, and availability impact on the vulnerable system.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2026-7261?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libphp` | Bitnami | From 8.2.0 | 8.2.31, 8.3.31, 8.4.21, 8.5.6 |
| `php` | Bitnami | From 8.2.0 | 8.2.31, 8.3.31, 8.4.21, 8.5.6 |
| `php-min` | Bitnami | From 8.2.0 | 8.2.31, 8.3.31, 8.4.21, 8.5.6 |

Products: Php Php.

## How do I fix CVE-2026-7261?

Upgrade libphp to a fixed version for your release line: 8.2.31, 8.3.31, 8.4.21 or 8.5.6.

## Is CVE-2026-7261 being exploited?

There is no known exploitation of CVE-2026-7261 in the wild and no public exploit code.

## Other vulnerabilities in Php Php

- [CVE-2012-2688](https://insights.sbomify.com/CVE-2012-2688/): Integer overflow in n/a (critical 10.0)
- [CVE-2012-2376](https://insights.sbomify.com/CVE-2012-2376/): Memory corruption in n/a (critical 10.0)
- [CVE-2011-3268](https://insights.sbomify.com/CVE-2011-3268/): Memory corruption in n/a (critical 10.0)
- [CVE-2009-4143](https://insights.sbomify.com/CVE-2009-4143/): Other in n/a (critical 10.0)
- [CVE-2008-5557](https://insights.sbomify.com/CVE-2008-5557/): Memory corruption in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-7261 and fix it if it is affected.

What it is: CVE-2026-7261 is a medium-severity use after free vulnerability in Php Php, published on 10 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-7261 in the wild and no public exploit code.

Affected packages and fixed versions:
- libphp (Bitnami): affected from 8.2.0; fixed in 8.2.31, 8.3.31, 8.4.21, 8.5.6
- php (Bitnami): affected from 8.2.0; fixed in 8.2.31, 8.3.31, 8.4.21, 8.5.6
- php-min (Bitnami): affected from 8.2.0; fixed in 8.2.31, 8.3.31, 8.4.21, 8.5.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-7261/ (Markdown: https://insights.sbomify.com/CVE-2026-7261/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-7261
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-7261
- OSV: https://osv.dev/vulnerability/CVE-2026-7261

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-7261/
Summaries are generated and may contain mistakes; the official description above is the record.
