CVE-2026-7262 NULL pointer dereference in SOAP apache:Map decoder with missing <value>
Remote attackers can crash PHP SOAP servers by sending malformed requests with missing value elements, causing a denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-7262?
CVE-2026-7262 is a low-severity vulnerability in Php Php, published on 10 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In PHP versions 8.2.* before 8.2.31, 8.3.* before 8.3.31, 8.4.* before 8.4.21, and 8.5.* before 8.5.6, when a SOAP server has a typemap configured, the decoding process contains a mistake which checks the wrong variable in case of missing value element. This leads to dereferences a NULL pointer, causing a segmentation fault. This allows a remote unauthenticated attacker to crash the PHP SOAP server process, resulting in denial of service.
Weakness: CWE-476
Which versions are affected by CVE-2026-7262?
3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
libphp Bitnami | From 8.2.0 | 8.2.31, 8.3.31, 8.4.21, 8.5.6 |
php Bitnami | From 8.2.0 | 8.2.31, 8.3.31, 8.4.21, 8.5.6 |
php-min Bitnami | From 8.2.0 | 8.2.31, 8.3.31, 8.4.21, 8.5.6 |
Products include Php Php.
How do I fix CVE-2026-7262?
Upgrade libphp to a fixed version for your release line: 8.2.31, 8.3.31, 8.4.21 or 8.5.6.
Is CVE-2026-7262 being exploited?
There is no known exploitation of CVE-2026-7262 in the wild and no public exploit code.
Other vulnerabilities in Php Php
Sources
Also known as AZL-86355, BELL-CVE-2026-7262, BIT-libphp-2026-7262, BIT-php-2026-7262, BIT-php-min-2026-7262, CLSA-2026-1779202666 and 8 more.