CVE-2026-7263 DoS attack via DOMNode::C14N()
Attackers can cause denial of service in PHP applications by triggering an infinite loop in DOMNode::C14N() via crafted XML data.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-7263?
CVE-2026-7263 is a medium-severity denial of service vulnerability in Php Php, published on 10 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In PHP versions 8.4.* before 8.4.21 and 8.5.* before 8.5.6, DOMNode::C14N() method may process the XML data incorrectly, causing a circular linked list in the data structure representing the XML document. This may cause subsequent processing of the XML document to enter infinite loop, causing denial of service in the processing application.
Which versions are affected by CVE-2026-7263?
3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
libphp Bitnami | From 8.4.0 | 8.4.21, 8.5.6 |
php Bitnami | From 8.4.0 | 8.4.21, 8.5.6 |
php-min Bitnami | From 8.4.0 | 8.4.21, 8.5.6 |
Products include Php Php.
How do I fix CVE-2026-7263?
Upgrade libphp to a fixed version for your release line: 8.4.21 or 8.5.6.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-7263 being exploited?
There is no known exploitation of CVE-2026-7263 in the wild and no public exploit code.
Other vulnerabilities in Php Php
Sources
Also known as BIT-libphp-2026-7263, BIT-php-2026-7263, BIT-php-min-2026-7263, DEBIAN-CVE-2026-7263, MINI-6gjw-744p-5m9w, MINI-wqw7-rmm7-r9h4 and 1 more.