# CVE-2026-72668: Unintended Proxy or Intermediary ('Confused Deputy') in Kibana Leading to Privilege Escalation

> A non-admin user can escalate privileges to full administrative control by manipulating shared agents in Kibana Agent Builder.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** BIT-elk-2026-72668, BIT-kibana-2026-72668, GHSA-r4ff-jqf2-8p5g, MINI-fm9w-337j-gjhw

## What is CVE-2026-72668?

CVE-2026-72668 is a high-severity vulnerability in Elastic Kibana, published on 26 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Unintended Proxy or Intermediary ('Confused Deputy') (CWE-441) in Kibana Agent Builder can lead to privilege escalation. A non-administrative user able to edit a shared agent could cause privileged operations to be carried out under the identity of a higher-privileged user who subsequently interacts with that agent. Where the same user can also author workflows, this can extend to full administrative control of Kibana and of the Elasticsearch cluster.

Weakness: CWE-441 (Unintended Proxy or Intermediary)

## Which versions are affected by CVE-2026-72668?

2 open source packages ship an affected version, including kibana and elk.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kibana` | Bitnami | From 9.4.0 | 9.4.7 |
| `elk` | Bitnami | From 9.4.0 | 9.4.7 |

## How do I fix CVE-2026-72668?

Upgrade kibana to 9.4.7 or later.

## Is CVE-2026-72668 being exploited?

There is no known exploitation of CVE-2026-72668 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-72668 and fix it if it is affected.

What it is: CVE-2026-72668 is a high-severity vulnerability in Elastic Kibana, published on 26 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-72668 in the wild and no public exploit code.

Affected packages and fixed versions:
- kibana (Bitnami): affected from 9.4.0; fixed in 9.4.7
- elk (Bitnami): affected from 9.4.0; fixed in 9.4.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-72668/ (Markdown: https://insights.sbomify.com/CVE-2026-72668/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-72668
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-72668
- OSV: https://osv.dev/vulnerability/CVE-2026-72668

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-72668/
Summaries are generated and may contain mistakes; the official description above is the record.
