# CVE-2026-72698: Grav CMS before 2.0.16 Information Disclosure via Twig Sandbox Bypass

> Content editors can bypass Twig sandbox restrictions to read sensitive configuration secrets in Grav CMS.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-p597-crqc-m349

## What is CVE-2026-72698?

CVE-2026-72698 is a high-severity vulnerability in getgrav grav, published on 25 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Grav CMS before 2.0.16 fails to filter system, site, and theme configuration arrays in sandboxed Twig renders, allowing content editors to read sensitive configuration values. Attackers with page-content edit access can access raw configuration arrays including secrets like cache credentials by using dot notation in Twig templates, bypassing the config_denied_paths restrictions.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-72698?

2 open source packages ship an affected version, including getgrav/grav.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getgrav/grav` | Packagist | All versions | 2.0.16 |
| `getgrav/grav` | Packagist | All versions | 2.0.16 |

## How do I fix CVE-2026-72698?

Upgrade getgrav/grav to 2.0.16 or later.

## Is CVE-2026-72698 being exploited?

There is no known exploitation of CVE-2026-72698 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-72698 and fix it if it is affected.

What it is: CVE-2026-72698 is a high-severity vulnerability in getgrav grav, published on 25 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-72698 in the wild and no public exploit code.

Affected packages and fixed versions:
- getgrav/grav (Packagist): affected all versions; fixed in 2.0.16
- getgrav/grav (Packagist): affected all versions; fixed in 2.0.16

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-72698/ (Markdown: https://insights.sbomify.com/CVE-2026-72698/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-72698
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-72698
- OSV: https://osv.dev/vulnerability/CVE-2026-72698

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-72698/
Summaries are generated and may contain mistakes; the official description above is the record.
