# CVE-2026-72701: Grav CMS before 2.0.16 Timing Attack via verifyNonce

> Attackers can bypass CSRF protection in Grav CMS by exploiting a timing side-channel in nonce validation to recover valid tokens.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-38p6-h87p-r4cg

## What is CVE-2026-72701?

CVE-2026-72701 is a medium-severity vulnerability in getgrav grav, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Grav CMS before 2.0.16 contains a timing vulnerability in Utils::verifyNonce() that uses non-constant-time string comparison with the === operator instead of hash_equals() for CSRF nonce validation. Attackers can measure response timing differences to recover valid nonce values byte-by-byte through multiple requests, weakening CSRF protection below its intended security margin.

Weakness: CWE-208 (Observable Timing Discrepancy)

## Which versions are affected by CVE-2026-72701?

2 open source packages ship an affected version, including getgrav/grav.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getgrav/grav` | Packagist | All versions | 2.0.16 |
| `getgrav/grav` | Packagist | All versions | 2.0.16 |

## How do I fix CVE-2026-72701?

Upgrade getgrav/grav to 2.0.16 or later.

## Is CVE-2026-72701 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-72701 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-72701 and fix it if it is affected.

What it is: CVE-2026-72701 is a medium-severity vulnerability in getgrav grav, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-72701 exists.

Affected packages and fixed versions:
- getgrav/grav (Packagist): affected all versions; fixed in 2.0.16
- getgrav/grav (Packagist): affected all versions; fixed in 2.0.16

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-72701/ (Markdown: https://insights.sbomify.com/CVE-2026-72701/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-72701
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-72701
- OSV: https://osv.dev/vulnerability/CVE-2026-72701

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-72701/
Summaries are generated and may contain mistakes; the official description above is the record.
