# CVE-2026-72702: Grav CMS before 2.0.16 Origin Validation Bypass via Referer

> Attackers can bypass origin validation in Grav CMS by spoofing the Referer header, allowing same-origin trust for malicious domains.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-9ccq-2jfg-qw33

## What is CVE-2026-72702?

CVE-2026-72702 is a critical vulnerability in getgrav grav, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Grav CMS before 2.0.16 contains an origin validation bypass in the Uri::referrer() and Pages::referrerRoute() methods, which validate the Referer header using an unanchored string prefix match (str_starts_with($referrer, $base)) with no trailing delimiter. An attacker who controls a domain that begins with the victim site's origin (e.g. https://example.com.attacker.tld) can send a request with such a Referer to be treated as same-origin, bypassing the Referer-based origin check.

Weakness: CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2026-72702?

2 open source packages ship an affected version, including getgrav/grav.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getgrav/grav` | Packagist | All versions | 2.0.16 |
| `getgrav/grav` | Packagist | All versions | 2.0.16 |

## How do I fix CVE-2026-72702?

Upgrade getgrav/grav to 2.0.16 or later.

## Is CVE-2026-72702 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-72702 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-72702 and fix it if it is affected.

What it is: CVE-2026-72702 is a critical vulnerability in getgrav grav, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-72702 exists.

Affected packages and fixed versions:
- getgrav/grav (Packagist): affected all versions; fixed in 2.0.16
- getgrav/grav (Packagist): affected all versions; fixed in 2.0.16

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-72702/ (Markdown: https://insights.sbomify.com/CVE-2026-72702/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-72702
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-72702
- OSV: https://osv.dev/vulnerability/CVE-2026-72702

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-72702/
Summaries are generated and may contain mistakes; the official description above is the record.
