# CVE-2026-72708: SPIP < 4.4.18 Unauthenticated Blind SQL Injection via sitemap.xml.html

> Unauthenticated attackers can extract arbitrary database content, including signing secrets, via blind SQL injection in the sitemap template.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Sep 2026
- **Updated:** 12 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-72708, GHSA-8c85-4pqf-wfwj, UBUNTU-CVE-2026-72708

## What is CVE-2026-72708?

CVE-2026-72708 is a high-severity SQL injection vulnerability in SPIP, published on 11 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

SPIP before 4.4.18 contains an unauthenticated blind SQL injection vulnerability in the SQL escaping layer that allows unauthenticated attackers to inject arbitrary SQL by supplying a crafted annee parameter value matching a word character followed by an open parenthesis, which bypasses escaping for date-type columns across MySQL, SQLite, and PostgreSQL backends. Attackers can exploit the always-present sitemap.xml.html template's annee criterion to embed unescaped time-based or boolean payloads into database queries, enabling extraction of arbitrary database content including the alea_ephemere secret used to sign SPIP action nonces.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-72708?


## How do I fix CVE-2026-72708?

Upgrade to a fixed version.

## Is CVE-2026-72708 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-72708 exists.

Public exploit code:

- spip exploits for CVE-2026-72708, CVE-2026-72709, CVE-2026-72710 (github_poc): https://github.com/ambionics/spip-exploits
- PoC for CVE-2026-72708 (blind SQLi) and CVE-2026-109378 (SSRF) in SPIP, both fixed in 4.4.18 (github_poc): https://github.com/ka3n1x/spip-cve-2026

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-72708 and fix it if it is affected.

What it is: CVE-2026-72708 is a high-severity SQL injection vulnerability in SPIP, published on 11 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-72708 exists.

Affected product: SPIP. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-72708/ (Markdown: https://insights.sbomify.com/CVE-2026-72708/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-72708
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-72708
- OSV: https://osv.dev/vulnerability/CVE-2026-72708

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-72708/
Summaries are generated and may contain mistakes; the official description above is the record.
