{"answers":{"affected":"2 open source packages ship an affected version, including orval.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-72716 exists.","fix":"Upgrade orval to 8.21.0 or later.","what":"CVE-2026-72716 is a critical code injection vulnerability in orval-labs orval, published on 19 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-72716 and fix it if it is affected.\n\nWhat it is: CVE-2026-72716 is a critical code injection vulnerability in orval-labs orval, published on 19 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-72716 exists.\n\nAffected packages and fixed versions:\n- orval (npm): affected all versions; fixed in 8.21.0\n- orval (npm): affected all versions; fixed in 8.21.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-72716/ (Markdown: https://insights.sbomify.com/CVE-2026-72716/index.md)","id":"CVE-2026-72716","markdown":"https://insights.sbomify.com/CVE-2026-72716/index.md","name":"CVE-2026-72716","record":{"aliases":["GHSA-p4cg-3328-rvfg","ROOT-APP-NPM-CVE-2026-72716"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenAPI client generator","requires_auth":"none","summary":"Attacker-controlled input in OpenAPI specs can execute arbitrary code during client generation or import, affecting developers and CI environments.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-1336","name":"Improper Neutralization of Special Elements Used in a Template Engine"}],"description":"Orval generates type-safe JavaScript clients in TypeScript from OpenAPI v3 and Swagger v2 specifications. Prior to 8.21.0, a ${...} expression or backtick in a query parameter default is emitted into a module-level template literal emitted by zod schema generation without safe encoding. This permits attacker-controlled JavaScript to be evaluated when the generated zod schema module is imported, resulting in code execution in the developer, CI, test, or application environment. The affected code is packages/zod/src/index.ts function formatDefaultValue. This issue is fixed in version 8.21.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Orval: Import-time RCE via query-parameter default -\u003e zod module-level template literal","id":"CVE-2026-72716","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":2,"n_references":4,"next":{"headline":"Orval: Import-time RCE via schema default -\u003e zod module-level template literal","id":"CVE-2026-72717"},"packages":[{"ecosystem":"npm","fixed":["8.21.0"],"introduced":["0"],"last_affected":[],"package":"orval","purl":null,"source":"GHSA-p4cg-3328-rvfg"},{"ecosystem":"npm","fixed":["8.21.0"],"introduced":["0"],"last_affected":[],"package":"orval","purl":"pkg:npm/orval","source":"GHSA-p4cg-3328-rvfg"}],"prev":{"headline":"Rocq Prover through 9.2.0 Universe Checking State Desynchronised After Module Close","id":"CVE-2026-72714"},"products":["orval"],"published":"2026-08-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-08-19","vendors":["orval-labs"]},"summary":"Attacker-controlled input in OpenAPI specs can execute arbitrary code during client generation or import, affecting developers and CI environments.","url":"https://insights.sbomify.com/CVE-2026-72716/"}