# CVE-2026-72720: Discourse: HTML injection in PrettyText.format_for_email from cooked-attribute reparsing

> Attackers can inject HTML into email previews via crafted attributes, potentially leading to script execution or account takeover in Discourse forums.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Aug 2026
- **Updated:** 10 Aug 2026
- **Also known as:** BIT-discourse-2026-72720, GHSA-3q6f-6gm9-m35v

## What is CVE-2026-72720?

CVE-2026-72720 is a medium-severity cross-site scripting vulnerability in discourse, published on 10 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Discourse is an open-source discussion platform. Prior to 2026.1.7, 2026.6.2, 2026.7.1, and 2026.8.0-latest.1, Discourse has HTML injection in PrettyText.format_for_email because cooked attribute values are reparsed as markup. Crafted Vimeo iframe sources, secure-upload URLs or dimensions, and hashtag data-slug values can cause decoded attribute text to be reinterpreted as HTML. The vulnerable conversion also fails to strictly validate the Vimeo iframe host and path, allowing non-Vimeo allowlisted iframes to be converted. This issue is fixed in versions 2026.1.7, 2026.6.2, 2026.7.1, and 2026.8.0-latest.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-72720?

1 open source package ship an affected version, including discourse.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 2026.1.7, 2026.6.2, 2026.7.1 |

## How do I fix CVE-2026-72720?

Upgrade discourse to a fixed version for your release line: 2026.1.7, 2026.6.2 or 2026.7.1.

## Is CVE-2026-72720 being exploited?

There is no known exploitation of CVE-2026-72720 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-72720 and fix it if it is affected.

What it is: CVE-2026-72720 is a medium-severity cross-site scripting vulnerability in discourse, published on 10 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-72720 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 2026.1.7, 2026.6.2, 2026.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-72720/ (Markdown: https://insights.sbomify.com/CVE-2026-72720/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-72720
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-72720
- OSV: https://osv.dev/vulnerability/CVE-2026-72720

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-72720/
Summaries are generated and may contain mistakes; the official description above is the record.
