# CVE-2026-72721: Discourse: Onebox Domain Blocklist Bypass via Case-Sensitive Comparison

> Attackers can bypass Onebox domain blocklists by using mixed-case hostnames, allowing unauthorized content embedding in Discourse forums.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Aug 2026
- **Updated:** 10 Aug 2026
- **Also known as:** BIT-discourse-2026-72721, GHSA-3x7x-24rq-h5j6

## What is CVE-2026-72721?

CVE-2026-72721 is a medium-severity vulnerability in discourse, published on 10 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Discourse is an open-source discussion platform. Prior to 2026.1.6, 2026.5.2, 2026.6.1, and 2026.7.0, Onebox::DomainChecker.is_blocked? compares hostnames and SiteSetting.blocked_onebox_domains entries case-sensitively, allowing an attacker to bypass configured Onebox domain restrictions by changing character casing in a redirect target hostname. This issue is fixed in versions 2026.1.6, 2026.5.2, 2026.6.1, and 2026.7.0.

Weakness: CWE-178 (Improper Handling of Case Sensitivity)

## Which versions are affected by CVE-2026-72721?

1 open source package ship an affected version, including discourse.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 2026.1.6, 2026.5.2, 2026.6.1 |

## How do I fix CVE-2026-72721?

Upgrade discourse to a fixed version for your release line: 2026.1.6, 2026.5.2 or 2026.6.1.

## Is CVE-2026-72721 being exploited?

There is no known exploitation of CVE-2026-72721 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-72721 and fix it if it is affected.

What it is: CVE-2026-72721 is a medium-severity vulnerability in discourse, published on 10 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-72721 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 2026.1.6, 2026.5.2, 2026.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-72721/ (Markdown: https://insights.sbomify.com/CVE-2026-72721/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-72721
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-72721
- OSV: https://osv.dev/vulnerability/CVE-2026-72721

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-72721/
Summaries are generated and may contain mistakes; the official description above is the record.
