# CVE-2026-72723: Discourse: Anonymous sidebar serialization exposes descriptions of category-restricted tags

> Unauthenticated attackers can view restricted tag names and descriptions via the site JSON endpoint, exposing category-restricted metadata.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Aug 2026
- **Updated:** 10 Aug 2026
- **Also known as:** BIT-discourse-2026-72723, GHSA-4p6q-h74v-5j7p

## What is CVE-2026-72723?

CVE-2026-72723 is a medium-severity vulnerability in discourse, published on 10 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Discourse is an open-source discussion platform. Prior to 2026.1.6, 2026.5.2, 2026.6.1, and 2026.7.0, SiteSerializer.anonymous_default_navigation_menu_tags serializes tags from SiteSetting.default_navigation_menu_tags without applying DiscourseTagging.filter_visible for the anonymous viewer. An unauthenticated user can retrieve restricted tag names and descriptions through /site.json when those tags are limited by inaccessible categories, category tag groups, or tag-group permissions. This issue is fixed in versions 2026.1.6, 2026.5.2, 2026.6.1, and 2026.7.0.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-72723?

1 open source package ship an affected version, including discourse.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 2026.1.6, 2026.5.2, 2026.6.1 |

## How do I fix CVE-2026-72723?

Upgrade discourse to a fixed version for your release line: 2026.1.6, 2026.5.2 or 2026.6.1.

## Is CVE-2026-72723 being exploited?

There is no known exploitation of CVE-2026-72723 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-72723 and fix it if it is affected.

What it is: CVE-2026-72723 is a medium-severity vulnerability in discourse, published on 10 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-72723 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 2026.1.6, 2026.5.2, 2026.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-72723/ (Markdown: https://insights.sbomify.com/CVE-2026-72723/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-72723
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-72723
- OSV: https://osv.dev/vulnerability/CVE-2026-72723

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-72723/
Summaries are generated and may contain mistakes; the official description above is the record.
