# CVE-2026-72724: Discourse: Private Chat Threat Message Disclosure via Chat Onebox Channel/Threat ID Mismatch

> An authenticated user can access private chat thread messages by mismatching channel and thread IDs in onebox requests, exposing sensitive data.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Aug 2026
- **Updated:** 11 Aug 2026
- **Also known as:** BIT-discourse-2026-72724, GHSA-8g98-fvfc-9w48

## What is CVE-2026-72724?

CVE-2026-72724 is a medium-severity missing authorization vulnerability in discourse, published on 10 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Discourse is an open-source discussion platform. Prior to 2026.1.6, 2026.5.2, 2026.6.1, and 2026.7.0, plugins/chat/lib/chat/onebox_handler.rb resolves Chat::Thread by route thread_id independently of the route channel_id before checking whether the user can preview the selected chat channel. An authenticated user can pair a public channel ID with a private thread ID in a /onebox.json request and obtain private thread message content. This issue is fixed in versions 2026.1.6, 2026.5.2, 2026.6.1, and 2026.7.0.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-72724?

1 open source package ship an affected version, including discourse.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 2026.1.6, 2026.5.2, 2026.6.1 |

## How do I fix CVE-2026-72724?

Upgrade discourse to a fixed version for your release line: 2026.1.6, 2026.5.2 or 2026.6.1.

## Is CVE-2026-72724 being exploited?

There is no known exploitation of CVE-2026-72724 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-72724 and fix it if it is affected.

What it is: CVE-2026-72724 is a medium-severity missing authorization vulnerability in discourse, published on 10 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-72724 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 2026.1.6, 2026.5.2, 2026.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-72724/ (Markdown: https://insights.sbomify.com/CVE-2026-72724/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-72724
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-72724
- OSV: https://osv.dev/vulnerability/CVE-2026-72724

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-72724/
Summaries are generated and may contain mistakes; the official description above is the record.
