CVE-2026-72725 Discourse: Stored XSS in staff action logs injects staff UI
Attackers can inject malicious scripts into staff action logs, leading to stored XSS in the staff interface of Discourse forums.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-72725?
CVE-2026-72725 is a medium-severity cross-site scripting vulnerability in discourse, published on 10 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Discourse is an open-source discussion platform. Prior to 2026.1.6, the staff action log model rendered unescaped previous and new value fields that could inject stored cross-site scripting into the staff interface. The issue is fixed in 2026.1.6, 2026.5.2, 2026.6.1, and 2026.7.0.
Weakness: CWE-79
Which versions are affected by CVE-2026-72725?
1 open source package ship an affected version, including discourse.
| Package | Affected | Fixed in |
|---|---|---|
discourse Bitnami | All versions | 2026.1.6, 2026.5.2, 2026.6.1 |
How do I fix CVE-2026-72725?
Upgrade discourse to a fixed version for your release line: 2026.1.6, 2026.5.2 or 2026.6.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-72725 being exploited?
There is no known exploitation of CVE-2026-72725 in the wild and no public exploit code.
Sources
Also known as BIT-discourse-2026-72725, GHSA-8x29-vv56-wj6v.