{"answers":{"affected":"1 open source package ship an affected version, including discourse.","exploited":"There is no known exploitation of CVE-2026-72725 in the wild and no public exploit code.","fix":"Upgrade discourse to a fixed version for your release line: 2026.1.6, 2026.5.2 or 2026.6.1.","what":"CVE-2026-72725 is a medium-severity cross-site scripting vulnerability in discourse, published on 10 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-72725 and fix it if it is affected.\n\nWhat it is: CVE-2026-72725 is a medium-severity cross-site scripting vulnerability in discourse, published on 10 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-72725 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- discourse (Bitnami): affected all versions; fixed in 2026.1.6, 2026.5.2, 2026.6.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-72725/ (Markdown: https://insights.sbomify.com/CVE-2026-72725/index.md)","id":"CVE-2026-72725","markdown":"https://insights.sbomify.com/CVE-2026-72725/index.md","name":"CVE-2026-72725","record":{"aliases":["BIT-discourse-2026-72725","GHSA-8x29-vv56-wj6v"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Discourse forum platform","requires_auth":"low_privilege","summary":"Attackers can inject malicious scripts into staff action logs, leading to stored XSS in the staff interface of Discourse forums.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Discourse is an open-source discussion platform. Prior to 2026.1.6, the staff action log model rendered unescaped previous and new value fields that could inject stored cross-site scripting into the staff interface. The issue is fixed in 2026.1.6, 2026.5.2, 2026.6.1, and 2026.7.0.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Discourse: Stored XSS in staff action logs injects staff UI","id":"CVE-2026-72725","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":1,"n_references":4,"next":{"headline":"Discourse: Unauthorized eavesdropping on private AI bot conversations.","id":"CVE-2026-72726"},"packages":[{"ecosystem":"Bitnami","fixed":["2026.1.6","2026.5.2","2026.6.1"],"introduced":["0","2026.5.0","2026.6.0"],"last_affected":[],"package":"discourse","purl":"pkg:bitnami/discourse","source":"BIT-discourse-2026-72725"}],"prev":{"headline":"Discourse: Private Chat Threat Message Disclosure via Chat Onebox Channel/Threat ID Mismatch","id":"CVE-2026-72724"},"products":["discourse"],"published":"2026-08-10","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-10","vendors":["discourse"]},"summary":"Attackers can inject malicious scripts into staff action logs, leading to stored XSS in the staff interface of Discourse forums.","url":"https://insights.sbomify.com/CVE-2026-72725/"}