CVE-2026-72727 Discourse: Stored XSS in the moderation review queue
Low-privileged users can execute stored XSS against moderators in Discourse if the default Content Security Policy is modified or disabled.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-72727?
CVE-2026-72727 is a medium-severity cross-site scripting vulnerability in discourse, published on 10 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Discourse is an open-source discussion platform. Prior to 026.1.6, 2026.5.2, 2026.6.1, and 2026.7.0, a low-privileged user could place crafted content in the moderation review queue that executed stored cross-site scripting when a moderator viewed it on a site with a modified or disabled default Content Security Policy. This issue is fixed in versions 2026.1.6, 2026.5.2, 2026.6.1, and 2026.7.0.
Weakness: CWE-79
Which versions are affected by CVE-2026-72727?
1 open source package ship an affected version, including discourse.
| Package | Affected | Fixed in |
|---|---|---|
discourse Bitnami | All versions | 2026.1.6, 2026.5.2, 2026.6.1 |
How do I fix CVE-2026-72727?
Upgrade discourse to a fixed version for your release line: 2026.1.6, 2026.5.2 or 2026.6.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-72727 being exploited?
There is no known exploitation of CVE-2026-72727 in the wild and no public exploit code.
Sources
Also known as BIT-discourse-2026-72727, GHSA-pq6q-p5g3-rj54.