# CVE-2026-72727: Discourse: Stored XSS in the moderation review queue

> Low-privileged users can execute stored XSS against moderators in Discourse if the default Content Security Policy is modified or disabled.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Aug 2026
- **Updated:** 13 Aug 2026
- **Also known as:** BIT-discourse-2026-72727, GHSA-pq6q-p5g3-rj54

## What is CVE-2026-72727?

CVE-2026-72727 is a medium-severity cross-site scripting vulnerability in discourse, published on 10 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Discourse is an open-source discussion platform. Prior to 026.1.6, 2026.5.2, 2026.6.1, and 2026.7.0, a low-privileged user could place crafted content in the moderation review queue that executed stored cross-site scripting when a moderator viewed it on a site with a modified or disabled default Content Security Policy. This issue is fixed in versions 2026.1.6, 2026.5.2, 2026.6.1, and 2026.7.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-72727?

1 open source package ship an affected version, including discourse.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 2026.1.6, 2026.5.2, 2026.6.1 |

## How do I fix CVE-2026-72727?

Upgrade discourse to a fixed version for your release line: 2026.1.6, 2026.5.2 or 2026.6.1.

## Is CVE-2026-72727 being exploited?

There is no known exploitation of CVE-2026-72727 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-72727 and fix it if it is affected.

What it is: CVE-2026-72727 is a medium-severity cross-site scripting vulnerability in discourse, published on 10 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-72727 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 2026.1.6, 2026.5.2, 2026.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-72727/ (Markdown: https://insights.sbomify.com/CVE-2026-72727/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-72727
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-72727
- OSV: https://osv.dev/vulnerability/CVE-2026-72727

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-72727/
Summaries are generated and may contain mistakes; the official description above is the record.
