CVE-2026-72728 Discourse: Onebox iframe origin allowlist enforces URL authority boundary
Authenticated users can bypass Onebox iframe origin allowlists to embed malicious content, potentially leading to code execution.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-72728?
CVE-2026-72728 is a medium-severity vulnerability in discourse, published on 10 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Discourse is an open-source discussion platform. Prior to 2026.1.7, an authenticated user could submit specially formed URLs that bypassed the Onebox allowlist and embedded malicious content in a site. This issue is fixed in versions 2026.1.7, 2026.6.2, 2026.7.1, and 2026.8.0-latest.1.
Weakness: CWE-20
Which versions are affected by CVE-2026-72728?
1 open source package ship an affected version, including discourse.
| Package | Affected | Fixed in |
|---|---|---|
discourse Bitnami | All versions | 2026.1.7, 2026.6.2, 2026.7.1 |
How do I fix CVE-2026-72728?
Upgrade discourse to a fixed version for your release line: 2026.1.7, 2026.6.2 or 2026.7.1.
Is CVE-2026-72728 being exploited?
There is no known exploitation of CVE-2026-72728 in the wild and no public exploit code.
Sources
Also known as BIT-discourse-2026-72728, GHSA-qp9j-3v7r-wrvr.