{"answers":{"affected":"1 open source package ship an affected version, including discourse.","exploited":"There is no known exploitation of CVE-2026-72728 in the wild and no public exploit code.","fix":"Upgrade discourse to a fixed version for your release line: 2026.1.7, 2026.6.2 or 2026.7.1.","what":"CVE-2026-72728 is a medium-severity vulnerability in discourse, published on 10 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-72728 and fix it if it is affected.\n\nWhat it is: CVE-2026-72728 is a medium-severity vulnerability in discourse, published on 10 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-72728 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- discourse (Bitnami): affected all versions; fixed in 2026.1.7, 2026.6.2, 2026.7.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-72728/ (Markdown: https://insights.sbomify.com/CVE-2026-72728/index.md)","id":"CVE-2026-72728","markdown":"https://insights.sbomify.com/CVE-2026-72728/index.md","name":"CVE-2026-72728","record":{"aliases":["BIT-discourse-2026-72728","GHSA-qp9j-3v7r-wrvr"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Discourse forum platform","requires_auth":"low_privilege","summary":"Authenticated users can bypass Onebox iframe origin allowlists to embed malicious content, potentially leading to code execution.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Discourse is an open-source discussion platform. Prior to 2026.1.7, an authenticated user could submit specially formed URLs that bypassed the Onebox allowlist and embedded malicious content in a site. This issue is fixed in versions 2026.1.7, 2026.6.2, 2026.7.1, and 2026.8.0-latest.1.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Discourse: Onebox iframe origin allowlist enforces URL authority boundary","id":"CVE-2026-72728","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"security_feature_bypass","year":"2026"},"n_packages":1,"n_references":2,"next":{"headline":"Discourse: Stored XSS in discourse-local-dates plugin","id":"CVE-2026-72729"},"packages":[{"ecosystem":"Bitnami","fixed":["2026.1.7","2026.6.2","2026.7.1"],"introduced":["0","2026.6.0","2026.7.0"],"last_affected":[],"package":"discourse","purl":"pkg:bitnami/discourse","source":"BIT-discourse-2026-72728"}],"prev":{"headline":"Discourse: Stored XSS in the moderation review queue","id":"CVE-2026-72727"},"products":["discourse"],"published":"2026-08-10","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-10","vendors":["discourse"]},"summary":"Authenticated users can bypass Onebox iframe origin allowlists to embed malicious content, potentially leading to code execution.","url":"https://insights.sbomify.com/CVE-2026-72728/"}