CVE-2026-72730 Discourse: Stored XSS chat-transcript username unescaped in Rich Text Editor

High 8.7 Published Updated

Attackers can inject malicious scripts via chat transcript usernames in the Rich Text Editor, potentially compromising user sessions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-72730?

CVE-2026-72730 is a high-severity cross-site scripting vulnerability in discourse, published on 10 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Discourse is an open-source discussion platform. Prior to 2026.1.6, 2026.5.2, 2026.6.1, and 2026.7.0, the Rich Text Editor rendered a chat-transcript username as HTML, allowing stored cross-site scripting. This issue is fixed in versions 2026.1.6, 2026.5.2, 2026.6.1, and 2026.7.0.

Weakness: CWE-79

Which versions are affected by CVE-2026-72730?

1 open source package ship an affected version, including discourse.

PackageAffectedFixed in
discourse BitnamiAll versions2026.1.6, 2026.5.2, 2026.6.1

How do I fix CVE-2026-72730?

Upgrade discourse to a fixed version for your release line: 2026.1.6, 2026.5.2 or 2026.6.1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-72730 being exploited?

There is no known exploitation of CVE-2026-72730 in the wild and no public exploit code.

Sources

Also known as BIT-discourse-2026-72730, GHSA-wg48-qxjc-f459.

Is CVE-2026-72730 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free