# CVE-2026-72732: Discourse: Templates endpoint exposes hidden tag names

> Attackers can view hidden tag names in Discourse forums due to missing permission checks in the templates endpoint, exposing restricted metadata.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Aug 2026
- **Updated:** 13 Aug 2026
- **Also known as:** BIT-discourse-2026-72732, GHSA-xrgc-52m8-82hm

## What is CVE-2026-72732?

CVE-2026-72732 is a medium-severity vulnerability in discourse, published on 10 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Discourse is an open-source discussion platform. Prior to 2026.1.6, 2026.5.2, 2026.6.1, and 2026.7.0, the discourse_templates endpoint exposed hidden tag names because DiscourseTemplates::TemplatesSerializer in plugins/discourse-templates/app/serializers/discourse_templates/templates_serializer.rb did not filter tags through the request Guardian. The serializer did not respect tag group permissions, allowing users to see tags they were not permitted to view. This issue is fixed in versions 2026.1.6, 2026.5.2, 2026.6.1, and 2026.7.0.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-72732?

1 open source package ship an affected version, including discourse.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 2026.1.6, 2026.5.2, 2026.6.1 |

## How do I fix CVE-2026-72732?

Upgrade discourse to a fixed version for your release line: 2026.1.6, 2026.5.2 or 2026.6.1.

## Is CVE-2026-72732 being exploited?

There is no known exploitation of CVE-2026-72732 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-72732 and fix it if it is affected.

What it is: CVE-2026-72732 is a medium-severity vulnerability in discourse, published on 10 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-72732 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 2026.1.6, 2026.5.2, 2026.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-72732/ (Markdown: https://insights.sbomify.com/CVE-2026-72732/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-72732
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-72732
- OSV: https://osv.dev/vulnerability/CVE-2026-72732

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-72732/
Summaries are generated and may contain mistakes; the official description above is the record.
