CVE-2026-72763 n8n before 1.123.67 Credential Exfiltration via Sub-Workflow
An Editor can exfiltrate unauthorized credentials by referencing them in sub-workflow JSON, bypassing access controls in n8n.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-72763?
CVE-2026-72763 is a high-severity missing authorization vulnerability in N8n N8n, published on 11 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
n8n before 1.123.67, 2.31.5, and 2.32.1 validates credential-access only for a node's top-level credentials and not for credentials referenced inside an Execute Sub-workflow node's inline workflow JSON. A member with Editor access to a shared workflow (when workflow sharing is enabled) who knows a target credential's ID can reference that credential in the inline JSON; it passes save-time and runtime validation and resolves in the parent workflow's project context, allowing the attacker to use or exfiltrate credentials they are not permitted to access.
Weakness: CWE-639
Which versions are affected by CVE-2026-72763?
6 open source packages ship an affected version, including n8n. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
n8n npm | All versions | 1.123.67 |
n8n npm | All versions | 1.123.67 |
n8n npm | From 2.0.0-rc.0 | 2.31.5 |
n8n npm | From 2.0.0-rc.0 | 2.31.5 |
n8n npm | From 2.32.0 | 2.32.1 |
n8n npm | From 2.32.0 | 2.32.1 |
Products include N8n N8n.
How do I fix CVE-2026-72763?
Upgrade n8n to a fixed version for your release line: 1.123.67, 2.31.5 or 2.32.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-72763 being exploited?
There is no known exploitation of CVE-2026-72763 in the wild and no public exploit code.
Other vulnerabilities in N8n N8n
- CVE-2025-68613 n8n Improper Control of Dynamically-Managed Code Resources
- CVE-2026-21877 n8n is vulnerable to Remote Code Execution via Arbitrary File Write
- CVE-2026-21858 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling
- CVE-2026-1470 n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution
- CVE-2025-68668 n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node
Sources
Also known as GHSA-9285-889v-mp3c, GHSA-cj9h-qx8g-pq2g, MINI-mvx7-m4f4-529r, MINI-v963-3vmx-6x5c, ROOT-APP-NPM-GHSA-cj9h-qx8g-pq2g.