# CVE-2026-72764: n8n before 1.123.67 Module Cache Poisoning via Code Node

> A user can poison the shared module cache in n8n's JS task runner, altering other users' Code-node executions and compromising confidentiality, integrity, or availability.

- **Severity:** Medium 5.8 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Aug 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-6fvf-89gw-r6cx, GHSA-9cmh-xcqm-5hqr, MINI-6rrx-29qc-7gpv, MINI-7r6r-gg3m-qvc2

## What is CVE-2026-72764?

CVE-2026-72764 is a medium-severity vulnerability in N8n N8n, published on 11 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

n8n's JavaScript task runner shared a single module cache across all users' Code-node executions. In affected versions (before 1.123.67, 2.31.5, and 2.32.1), a user able to run a Code node could poison a cached module and thereby alter other users' Code-node executions on the same runner, affecting their confidentiality, integrity, or availability. This is a cross-user isolation break within a single n8n instance and does not constitute a sandbox escape or remote code execution. Only multi-user instances running the JS task runner with built-in or external modules enabled are affected.

Weakness: CWE-668 (Exposure of Resource to Wrong Sphere)

## Which versions are affected by CVE-2026-72764?

6 open source packages ship an affected version, including n8n. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `n8n` | npm | All versions | 1.123.67 |
| `n8n` | npm | All versions | 1.123.67 |
| `n8n` | npm | From 2.0.0-rc.0 | 2.31.5 |
| `n8n` | npm | From 2.0.0-rc.0 | 2.31.5 |
| `n8n` | npm | From 2.32.0 | 2.32.1 |
| `n8n` | npm | From 2.32.0 | 2.32.1 |

Products: N8n N8n.

## How do I fix CVE-2026-72764?

Upgrade n8n to a fixed version for your release line: 1.123.67, 2.31.5 or 2.32.1.

## Is CVE-2026-72764 being exploited?

There is no known exploitation of CVE-2026-72764 in the wild and no public exploit code.

## Other vulnerabilities in N8n N8n

- [CVE-2025-68613](https://insights.sbomify.com/CVE-2025-68613/): n8n Improper Control of Dynamically-Managed Code Resources (critical 10.0, exploited in the wild)
- [CVE-2026-21877](https://insights.sbomify.com/CVE-2026-21877/): n8n is vulnerable to Remote Code Execution via Arbitrary File Write (critical 10.0)
- [CVE-2026-21858](https://insights.sbomify.com/CVE-2026-21858/): n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling (critical 10.0)
- [CVE-2026-1470](https://insights.sbomify.com/CVE-2026-1470/): n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution (critical 9.9)
- [CVE-2025-68668](https://insights.sbomify.com/CVE-2025-68668/): n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-72764 and fix it if it is affected.

What it is: CVE-2026-72764 is a medium-severity vulnerability in N8n N8n, published on 11 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-72764 in the wild and no public exploit code.

Affected packages and fixed versions:
- n8n (npm): affected all versions; fixed in 1.123.67
- n8n (npm): affected all versions; fixed in 1.123.67
- n8n (npm): affected from 2.0.0-rc.0; fixed in 2.31.5
- n8n (npm): affected from 2.0.0-rc.0; fixed in 2.31.5
- n8n (npm): affected from 2.32.0; fixed in 2.32.1
- n8n (npm): affected from 2.32.0; fixed in 2.32.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-72764/ (Markdown: https://insights.sbomify.com/CVE-2026-72764/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-72764
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-72764
- OSV: https://osv.dev/vulnerability/CVE-2026-72764

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-72764/
Summaries are generated and may contain mistakes; the official description above is the record.
