CVE-2026-72765 n8n before 2.32.1 Remote Code Execution via Expression Sandbox Escape
Authenticated users can execute arbitrary system commands on the host by crafting malicious expressions that bypass the sandbox in n8n.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-72765?
CVE-2026-72765 is a high-severity code injection vulnerability in N8n N8n, published on 11 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
n8n before 2.31.5 and before 2.32.1 contain a sandbox escape vulnerability in expression evaluation. An authenticated user with permission to create or modify workflows can craft expressions using arrow-function bodies to bypass the expression sandbox, triggering system command execution on the host running n8n. The issue is fixed in versions 2.31.5 and 2.32.1.
Weakness: CWE-94
Which versions are affected by CVE-2026-72765?
4 open source packages ship an affected version, including n8n. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
n8n npm | All versions | 2.31.5 |
n8n npm | All versions | 2.31.5 |
n8n npm | From 2.32.0 | 2.32.1 |
n8n npm | From 2.32.0 | 2.32.1 |
Products include N8n N8n.
How do I fix CVE-2026-72765?
Upgrade n8n to a fixed version for your release line: 2.31.5 or 2.32.1.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-72765 being exploited?
There is no known exploitation of CVE-2026-72765 in the wild and no public exploit code.
Other vulnerabilities in N8n N8n
- CVE-2025-68613 n8n Improper Control of Dynamically-Managed Code Resources
- CVE-2026-21877 n8n is vulnerable to Remote Code Execution via Arbitrary File Write
- CVE-2026-21858 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling
- CVE-2026-1470 n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution
- CVE-2025-68668 n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node
Sources
Also known as GHSA-32pm-g48p-fxhq, GHSA-gv7g-jm28-cr3m, MINI-g7rf-gfj6-rr9c, MINI-qppq-4q6j-2wc5, ROOT-APP-NPM-GHSA-gv7g-jm28-cr3m.