CVE-2026-72766 n8n before 1.123.67 Arbitrary File Read via Send Email Node
Attackers can read arbitrary local files and trigger SSRF via crafted non-string inputs in the Send Email node of n8n workflows.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-72766?
CVE-2026-72766 is a high-severity path traversal vulnerability in N8n N8n, published on 11 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
n8n before 1.123.67, 2.x before 2.31.5, and 2.32.x before 2.32.1 contain a type confusion vulnerability in the Send Email node, which does not enforce that its message fields are strings. A crafted non-string value supplied from a workflow expression into the text or HTML body field can be interpreted by the underlying mail library (Nodemailer) as a file path or URL, allowing arbitrary local file disclosure and server-side request forgery (SSRF). Exploitation requires a pre-existing active workflow with an unauthenticated webhook, valid SMTP credentials configured on the node, and untrusted input mapped directly into the body field; this is not a default configuration.
Weakness: CWE-843
Which versions are affected by CVE-2026-72766?
6 open source packages ship an affected version, including n8n. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
n8n npm | All versions | 1.123.67 |
n8n npm | All versions | 1.123.67 |
n8n npm | From 2.0.0-rc.0 | 2.31.5 |
n8n npm | From 2.0.0-rc.0 | 2.31.5 |
n8n npm | From 2.32.0 | 2.32.1 |
n8n npm | From 2.32.0 | 2.32.1 |
Products include N8n N8n.
How do I fix CVE-2026-72766?
Upgrade n8n to a fixed version for your release line: 1.123.67, 2.31.5 or 2.32.1.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2026-72766 being exploited?
There is no known exploitation of CVE-2026-72766 in the wild and no public exploit code.
Other vulnerabilities in N8n N8n
- CVE-2025-68613 n8n Improper Control of Dynamically-Managed Code Resources
- CVE-2026-21877 n8n is vulnerable to Remote Code Execution via Arbitrary File Write
- CVE-2026-21858 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling
- CVE-2026-1470 n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution
- CVE-2025-68668 n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node
Sources
Also known as GHSA-2x35-3fw4-9jr4, GHSA-9x27-5f6j-72hw, MINI-7j9v-qf8f-jjwf, MINI-vvcf-92jx-63ph, ROOT-APP-NPM-GHSA-2x35-3fw4-9jr4.